Bug 547496 - libguestfs appliance should Require shared library versions
libguestfs appliance should Require shared library versions
Status: CLOSED RAWHIDE
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-14 14:45 EST by Richard W.M. Jones
Modified: 2010-03-16 13:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 12:20:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-12-14 14:45:15 EST
When the libguestfs appliance is built, it contains implicit
dependencies on various shared libraries in the host.  As a
specific example, when libguestfs 1.0.79 was built, the version
of NTFS-3g it was built against was ntfs-3g-2009.4.4-3.fc12.x86_64
which contained the library:

  /lib64/libntfs-3g.so.54

Now however an updated NTFS-3g package has been added to F12
which contains the library:

  /lib64/libntfs-3g.so.71

libguestfs doesn't explicitly link to the old library, but it does
contain a reference to it in
/usr/lib64/guestfs/initramfs.fedora-12.x86_64.supermin.hostfiles

As a result, if you try to mount an NTFS partition after upgrading
NTFS-3g, it fails because the appliance won't contain the newer library.

The solution would be to add the Requires line to the libguestfs
RPM, so we get a broken dependency which we can fix (or the library
maintainer can fix).

An alternate solution would be to broaden the wildcard in the
supermin.hostfiles file, so it would choose either library,
at the risk of pulling in lots of unnecessary stuff.

Version-Release number of selected component (if applicable):

libguestfs 1.0.79
Comment 1 Richard W.M. Jones 2009-12-21 08:06:51 EST
I added this very experimental patch into Rawhide:

http://cvs.fedoraproject.org/viewvc/devel/libguestfs/libguestfs.spec?r1=1.117&r2=1.118
Comment 2 Richard W.M. Jones 2009-12-21 12:22:20 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=1883031
Comment 3 Richard W.M. Jones 2010-01-25 12:20:39 EST
This is now up and running in Rawhide and F-12.

Note You need to log in before you can comment on or make changes to this bug.