Bug 547499 - synfig-debuginfo-0.62.00-1.fc13 contains no sources
synfig-debuginfo-0.62.00-1.fc13 contains no sources
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: synfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-12-14 14:48 EST by Ville Skyttä
Modified: 2009-12-23 22:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-23 22:34:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-12-14 14:48:26 EST
synfig-debuginfo-0.62.00-1.fc13 contains no sources; based on build logs it seems -g got removed from CXXFLAGS:

http://kojipkgs.fedoraproject.org/packages/synfig/0.62.00/1.fc13/data/logs/x86_64/build.log

The package contains and applies synfig-0.61.09-optflags.patch which patches configure.ac, but there's no autotools invocation in %prep.  Shouldn't there be, or is it supposed to end up in configure some other way?

configuring with --disable-dependency-tracking could provide more readable build logs and a possible slight speedup, BTW.

Also (unrelated), the package appears to build a private copy of libltdl, is that intentional?
Comment 1 Ville Skyttä 2009-12-21 11:59:32 EST
0.62.00-2 appears to have the same issues.

(Ccing reviewer because this was missed in #531773)
Comment 2 Ville Skyttä 2009-12-23 10:07:11 EST
(In reply to comment #0)
> synfig-debuginfo-0.62.00-1.fc13 contains no sources; based on build logs it
> seems -g got removed from CXXFLAGS:

https://fedoraproject.org/wiki/Packaging:Guidelines#Debuginfo_packages

> Also (unrelated), the package appears to build a private copy of libltdl, is
> that intentional?  

https://fedoraproject.org/wiki/Packaging:Guidelines#Duplication_of_system_libraries
Comment 3 Lubomir Rintel 2009-12-23 22:34:32 EST
Thanks for the report

(In reply to comment #0)
> synfig-debuginfo-0.62.00-1.fc13 contains no sources; based on build logs it
> seems -g got removed from CXXFLAGS:
> 
> http://kojipkgs.fedoraproject.org/packages/synfig/0.62.00/1.fc13/data/logs/x86_64/build.log
> 
> The package contains and applies synfig-0.61.09-optflags.patch which patches
> configure.ac, but there's no autotools invocation in %prep.  Shouldn't there
> be, or is it supposed to end up in configure some other way?

In fact this used to work in earlier versions of package, but I dropped call to autoreconf at rebase to 0.62, not realizing it's still needed. Fix in devel now.

> configuring with --disable-dependency-tracking could provide more readable
> build logs and a possible slight speedup, BTW.

I'm not doing to do this. Dependency tracking may not be useful for this particular package, but I am reluctant to enable or disable it on per-package basis; it's just too much hassle. If you believe it's generally useless, please try to convince autoconf maintainers.

> Also (unrelated), the package appears to build a private copy of libltdl, is
> that intentional?

It's not. I dropped the bundled libltdl copy in Rawhide package now.

New package is synfig-0.62.00-3.fc13

Note You need to log in before you can comment on or make changes to this bug.