Bug 54751 - util-linux-2.11f-11.7.1 broke normal user
util-linux-2.11f-11.7.1 broke normal user
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2001-10-17 16:44 EDT by Alfredo Ferrari
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-17 16:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alfredo Ferrari 2001-10-17 16:44:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
After upgrading to util-linux-2.11f-11.7.1 (and glibc-2.2.4-19) every
normal user login which is not a xterm or similar is ending up in an error

Warning: no access to tty (Inappropriate ioctl for device).
Thus no job control in this shell.

and then there is no tty allocated (question marks when issuing ps where
usually there is pts/nn) and the shell is not working.
This occurs ALWAYS when connecting to a text console or telneting into the
machine. It seems something is badly broken during pts device
allocation/opening. Downgrading to util-linux-2.10s-13.7 solves the issue.
I upgraded/downgraded util-linux 3 times with a perfect reproducibility of
the bug. The system is a Dell Precision 420 with RH7.1 + all updates

LATEST NEWS: the bug is confirmed on a Dell Latitude C800 (the machine I am
writing on) with still the old glibc-2.2.2-10 (that is only util-linux
updated among the last bunch of updates). The problem disappear again
downgrading back util-linux

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install util-linux-2.11f-11.7.1
2.connect to a console as a normal user (ctrl+alt+f1...6) or telnet into
the machine
3.look at the result....

Actual Results:  the pts device does not seem to be properly allocated and
the shell does not work as advertised by the error message

Expected Results:  normal login

Additional info:
Comment 1 Elliot Lee 2001-10-17 16:58:24 EDT

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.