Bug 547553 - [abrt] crash detected in xfce4-xkb-plugin-0.5.3.3-1.fc12
Summary: [abrt] crash detected in xfce4-xkb-plugin-0.5.3.3-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-xkb-plugin
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f68bc6a9d17c93c61e853279a4d...
: 546100 555972 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-14 22:19 UTC by Konstantin Svist
Modified: 2010-02-23 05:35 UTC (History)
1 user (show)

Fixed In Version: xfce4-xkb-plugin-0.5.3.3-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 05:16:48 UTC


Attachments (Terms of Use)
File: backtrace (9.80 KB, text/plain)
2009-12-14 22:19 UTC, Konstantin Svist
no flags Details
backtrace (7.98 KB, text/plain)
2010-01-05 22:38 UTC, Konstantin Svist
no flags Details
coredump (3.77 MB, application/octet-stream)
2010-01-05 22:39 UTC, Konstantin Svist
no flags Details


Links
System ID Priority Status Summary Last Updated
Xfce 6123 None None None Never

Description Konstantin Svist 2009-12-14 22:19:09 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. 
2.
3.


Attached file: backtrace
cmdline: /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin socket_id 31457325 name xkb-plugin id 12604068180 display_name Keyboard Layouts size 50 screen_position 11
component: xfce4-xkb-plugin
executable: /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin
kernel: 2.6.31.6-166.fc12.i686
package: xfce4-xkb-plugin-0.5.3.3-1.fc12
rating: 4
reason: Process was terminated by signal 6

Comment 1 Konstantin Svist 2009-12-14 22:19:11 UTC
Created attachment 378376 [details]
File: backtrace

Comment 2 Konstantin Svist 2009-12-14 22:27:13 UTC
I don't know what the exact conditions need to be, but I was simply switching language by clicking the icon. As it crashed, the language became locked in for all apps (setting is to change language per application)

Comment 3 Konstantin Svist 2009-12-14 22:29:00 UTC
*** Bug 546100 has been marked as a duplicate of this bug. ***

Comment 4 Konstantin Svist 2010-01-05 21:35:16 UTC
I finally figured out how to get abrt to work right -- it expects debuginfo repos to be enabled in the config files.
However, now it refuses to upload the backtrace and just points to this bug.
Should I close this one so it would upload the backtrace?

Comment 5 Christoph Wickert 2010-01-05 21:43:29 UTC
Do what you like. You can ether close this bug and open a new one or manually attach the backtrace to this one.

Comment 6 Konstantin Svist 2010-01-05 22:35:00 UTC
not sure how to manually attach it, abrt doesn't make it too easy

Comment 7 Konstantin Svist 2010-01-05 22:38:55 UTC
Created attachment 381868 [details]
backtrace

apparently it still points to this bug; found where it stores the files

Comment 8 Konstantin Svist 2010-01-05 22:39:42 UTC
Created attachment 381869 [details]
coredump

Comment 9 Christoph Wickert 2010-01-06 16:04:56 UTC
(In reply to comment #4)
> I finally figured out how to get abrt to work right -- it expects debuginfo
> repos to be enabled in the config files.

Normally this shouldn't be necessary, the repos are enabled on demand. Not sure why it doesn't work for you, but at least we have a good backtrace now.

Forwarded upstream as http://bugzilla.xfce.org/show_bug.cgi?id=6123

Comment 10 Christoph Wickert 2010-02-12 00:07:32 UTC
*** Bug 555972 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2010-02-12 00:59:18 UTC
xfce4-xkb-plugin-0.5.3.3-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-3.fc12

Comment 12 Fedora Update System 2010-02-12 00:59:49 UTC
xfce4-xkb-plugin-0.5.3.3-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-3.fc11

Comment 13 Fedora Update System 2010-02-13 00:38:21 UTC
xfce4-xkb-plugin-0.5.3.3-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-xkb-plugin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-1827

Comment 14 Fedora Update System 2010-02-13 00:39:19 UTC
xfce4-xkb-plugin-0.5.3.3-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-xkb-plugin'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1834

Comment 15 Fedora Update System 2010-02-23 05:16:39 UTC
xfce4-xkb-plugin-0.5.3.3-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-02-23 05:35:01 UTC
xfce4-xkb-plugin-0.5.3.3-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.