Bug 54756 - Cannot boot after using up2date to update kernel
Cannot boot after using up2date to update kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-17 18:39 EDT by Richard Gugeler
Modified: 2015-01-07 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 12:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Gugeler 2001-10-17 18:39:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
First I ran up2date (version 2.5.4-x) as a GUI to update from 2.4.2 to the 
latest version.  This downloaded the .rpm file but failed with a message I 
didn't think to write down.  It had something to do with being unable to 
verify header information.  Since things often work better from the 
command prompt, I ran "up2date kernel" from a terminal window and all 
indications were that it completed successfully.

I checked lilo.conf and the new kernel information was in place and 
identical to the old information (except for the image= tag).  To make 
sure, I ran lilo.

However, when I rebooted, the process displayed "LIL-" and halted.  (I'm 
still working on getting my system back up.)  Note that this is a multi-
boot system with the /boot directory and lilo installed on a separate 
partition (/dev/hde2).  The other operating systems continue to boot 
without problems.

I tried changing lilo to boot the old kernel but, of course, this failed 
since the boot process never gets that far.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Run the command "up2date kernel"
2. Reboot
3.
	

Actual Results:  System fails to boot.

Expected Results:  I rather expected the system to boot with the new 
kernel.

Additional info:
Comment 1 Richard Gugeler 2001-10-19 18:25:11 EDT
Adding to the previous information, I also ran "lilo -u" which, I understand, 
should uninstall the boot sector and replace it with the old one.  The 
following messages were displayed:

"Reading boot sector from /dev/hde2"
"Fatal: Boot sector of /dev/hde2 doesn't have a LILO signature."

That interested me since I had used lilo to install it.

I also should note that I was a little hasty to say that my other operating 
systems still booted.  The Windows 2000 Server installation in the adjacent 
partition kept repeating the login screen.

Since I hadn't placed any important information on the drive, I adopted the 
draconian measure of wiping and repartioning the drive.  Now I'm re-installing 
everything.

Note:  I just was told that I should have run "fdisk /mbr" and then reinstalled 
the NT loader.  I don't know if that would have fixed the "LIL-" problem.  BTW, 
there seems to be no information about correcting a "LIL-" problem; only the 
information that this means that the "descriptor table" is "corrupt" without 
saying what the descriptor table is or how to uncorrupt it.


Comment 2 Adrian Likins 2001-10-24 16:57:40 EDT
Hmm. This sounds like it's probabaly actually a lilo bug. The up2date
client will change the config file, and run lilo in test mode, and
if succesful, run lilo in live mode. 

The fact that running lilo by itself seems to indicate that the config
file was valid.  It is possible that the config file was valid, but
incorrect, but I havent really seen any other reports of this.

Configuration errors generally are found when installing the bootloader.
I dont suppose you have access to the lilo.conf that was created and installed?


Comment 3 Richard Gugeler 2001-10-25 10:17:33 EDT
I'm not sure if I still have that lilo.conf file.  I had to repartition my 
system and do a clean install.  I'll check to see if I made a copy.  It looked 
the same as any other lilo.conf I've seen.
Comment 4 Richard Gugeler 2001-10-26 12:42:42 EDT
I'm afraid that I didn't keep a copy of lilo.conf before wiping my system 
(again).  I do remember examining it carefully and finding nothing unusual.

BTW, although you said you hadn't seen this problem before, I notice that in 
the user forums there's at least one message from a person who had the exact 
same problem after using up2date to update his kernel.

Comment 5 Adrian Likins 2002-03-26 18:36:27 EST
I belive most of the kernel/bootloader related issues should
be fixed in current versions of the client so I'm closing this
bug out.

If that is not the case, please reopen.

Note You need to log in before you can comment on or make changes to this bug.