Bug 54758 - scp does not take a -1 option to force it to use ssh1 protocol
scp does not take a -1 option to force it to use ssh1 protocol
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-17 19:37 EDT by Michael Meissner
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-17 19:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Meissner 2001-10-17 19:37:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.10-ac4 i686)

Description of problem:
The scp command does not take a -1 option like the ssh command does to
force it to use the ssh1 prototcol.  I imagine it probably doesn't take a
-2 option to force the use of ssh2 protocol either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to scp to a ssh1 machine without modifying /etc/ssh/ssh_config to
hardwire the protocol to version 1.
2.
3.
	

Actual Results:  You get the normal unknown switch message.

Expected Results:  scp should take equivalent options to ssh.

Additional info:
Comment 1 Nalin Dahyabhai 2002-03-07 12:35:25 EST
scp shouldn't offer every one of ssh's command-line options, and it doesn't need
to.  Use '-o "protocol 1"' to force scp to use protocol 1.

Marking as "won't fix" because I've seen this come up on the developer mailing
list before, and this tends to be the answer, and we don't want to change it
from the upstream default.

Note You need to log in before you can comment on or make changes to this bug.