Bug 54759 - CDL flavor 'bool' or 'none' must be boolean
Summary: CDL flavor 'bool' or 'none' must be boolean
Status: CLOSED WONTFIX
Alias: None
Product: eCos
Classification: Retired
Component: ConfigTool   
(Show other bugs)
Version: CVS
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bart Veer
QA Contact: ecc-bugs-int
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-18 00:22 UTC by George Thomas
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-20 16:03:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Thomas 2001-10-18 00:22:45 UTC
Description of Problem:
CDL objects with no flavor (or bool) should only allow
boolean values (since that's how they are treated).

Version-Release number of selected component (if applicable):


How Reproducible:
100%

Steps to Reproduce:
1. CDL object with no 'flavor'
2. set default_value to 999
3. 

This, IMHO, should be an error since the resulting #define will only
have the value 1 or not be defined if the value was 0.

Actual Results:


Expected Results:


Additional Information:

Comment 1 Alex Schuilenburg 2003-06-20 16:03:35 UTC
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=54759


Note You need to log in before you can comment on or make changes to this bug.