Bug 54767 - Can't handling family name for mincho and gothic
Summary: Can't handling family name for mincho and gothic
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: eel   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-18 09:28 UTC by Akira TAGOH
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-08 04:03:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I have a patch. (352 bytes, patch)
2001-10-18 09:28 UTC, Akira TAGOH
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:145 normal SHIPPED_LIVE New Japanese and Korean font packages available 2001-10-31 05:00:00 UTC

Description Akira TAGOH 2001-10-18 09:28:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Can't choose those family name because it is included the black lists.
However the fonts which has it exists mostly. those fonts is also useful.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install ttfonts-ja-1.0-7
2.Restart xfs
3.See Preferences of Nautilus
	

Actual Results:  Doesn't see those family name on font lists.

Expected Results:  Can see those family name.

Additional info:

Comment 1 Akira TAGOH 2001-10-18 09:28:55 UTC
Created attachment 34341 [details]
I have a patch.

Comment 2 Havoc Pennington 2001-10-18 15:22:19 UTC
Obvious question: why are the fonts in the blacklist? Surely someone had a
reason for that.

Comment 3 Akira TAGOH 2001-10-19 06:52:56 UTC
AFAIK those entries has existed in the black lists since it was made. I'm not
sure it seems that they thought they aren't useful. However it has motion which
corrects it because the fonts using XLFD which is not much desirable existed
mostly. so I think that list should be fixed.

Comment 4 Preston Brown 2001-11-01 16:59:58 UTC
fixing in eel-1.0.2-2.


Comment 5 Preston Brown 2001-11-01 17:34:25 UTC
fixed in an upcoming errata.

Comment 6 Havoc Pennington 2001-11-01 18:55:35 UTC
From Darin:

  Ramiro added the blacklist because of bugs that happened with bad fonts. I
  don't know what was bad about the fonts, but I remember that the bugs
  included both crashing problems and incorrect display of various types.

  I've never thought that recognizing these "bad fonts" by name was a good
  idea. But I also have no idea what might go wrong if we don't filter them
  out.

I forgot to ask him about this earlier, sorry... given the vagueness we should
probably just try removing the fonts from the blacklist and see if it breaks.


Comment 7 Alexandre Oliva 2001-11-08 04:03:25 UTC
eel-devel-1.0.2-2 should be pushed out too, otherwise someone who installed both
eel and eel-devel won't be able to update eel, because eel-devel-1.0.1 requires
eel = 1.0.1.


Comment 8 Preston Brown 2001-11-08 14:28:23 UTC
eel-devel is now included.


Comment 9 Bryan Headley 2001-11-08 16:19:02 UTC
11/8/2001 - Have not seen eel-devel-1.0.2-2 shipped out yet. Made by rebuilding
srpms file.


Note You need to log in before you can comment on or make changes to this bug.