Bug 547701 - fedora-kde-icon-theme : kickout of kde-settings, package separately
fedora-kde-icon-theme : kickout of kde-settings, package separately
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 547916
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2009-12-15 08:24 EST by Rex Dieter
Modified: 2010-01-05 16:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 16:43:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-12-15 08:24:14 EST
Kick fedora-kde icon theme out of kde-settings, package separately.
Comment 1 Kevin Kofler 2009-12-15 12:23:55 EST
It should also get installed into /usr/share/icons directly, not inside the kde-settings profile. That way, GTK+ apps would get the theme applied automatically through xsettings-kde.
Comment 2 Rex Dieter 2009-12-15 12:53:23 EST
Right (though gtk apps should still be finding it as-is, due to our setting of $XDG_DATA_DIRS)
Comment 3 Kevin Kofler 2009-12-15 20:28:43 EST
It doesn't find it. In fact hiding it from GTK+ is why we put it there in the first place. I just don't understand anymore why we did that. Well, I think we did it to keep Fedora-KDE out of the menus in other desktops, but I don't think that's a good idea after all, as it breaks KDE integration for GTK+ apps.
Comment 4 Rex Dieter 2009-12-15 23:17:33 EST
Meh, ok, though that should be a GTK+ bug not respecting XDG_DATA_DIRS here.
Comment 5 Kevin Kofler 2009-12-15 23:33:26 EST
Icons are not XDG data, the icon-naming-spec says they must be in /usr/share/icons. What makes icons in the kde-settings profile directory work in KDE is KDE's special support for profiles, which is not mentioned in the spec.
Comment 6 Rex Dieter 2010-01-05 16:43:34 EST
* Tue Jan 05 2010 Rex Dieter <rdieter@fedoraproject.org> 4.4-7
- externalize fedora-kde-icon-theme (#547701)

Note You need to log in before you can comment on or make changes to this bug.