Bug 54775 - Repeating Custom install damages existing setup
Repeating Custom install damages existing setup
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-18 11:45 EDT by Richard Gugeler
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-18 11:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Gugeler 2001-10-18 11:45:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Trying to fix the boot problem caused by using up2date to update the 
kernel, I ran a new Custom installation to try to reinstall the original 
kernel.

I made sure all package options were deselected on the main display so 
nothing would be installed except the kernel files.  At the Disk Druid 
dialog, I had to recreate all the mount points (it would have been handy 
if the existing setup were brought in automatically).  I chose to install 
LILO to the separate /boot partition (hde2) and to format only the /boot 
partition (so I wouldn't lose my existing setup).

Without any type of notification, the installer copied 224Mb of files, 
only 25Mb of which were related to the kernel.  This overwrote newer 
versions of several applications, including gcc and util-linux.

Even worse, when I finally started Linux again (using a boot disk since my 
boot problem wasn't solved), Gnome didn't start automatically, leaving me 
with only a command prompt.  (I'm still trying to figure out how to get 
Gnome back.  I supect I've lost all my dialer settings, etc.)


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Run Custom installation over an existing installation
2.
3.
	

Actual Results:  Installed files I had not selected, overwrote new apps 
with old versions and destroyed my setup.  I suspect I'll have to 
completely reinstall Linux from scratch.  Needless to say, between the 
up2date and anaconda problems, this is becoming a very frustrating 
experience.

Expected Results:  I expected it to simply format /boot and replace the 
kernel files.  If it's going to install 200Mb of unasked-for files, there 
should at least be some warning so I could have stopped the process.

Additional info:
Comment 1 Brent Fox 2001-10-19 17:41:49 EDT
Umm, you completely reinstalled your system from scratch.  In other words, the
partitions that you set mount points for in Disk Druid were formatted, erasing
all data.  The 225MB of data that you saw is the base install for Red Hat
Linux...the smallest amount of packages that you can install and have a working
Red Hat system.  So you can't just install the kernel, because there's no
bootloader, no system libraries, etc.  This explains why GNOME and such
disappeared.  

The installer is designed for three things.  One is to perform a full
installation on a system that does not have Red Hat Linux on it.  Two is to
upgrade an existing installation to a newer version.  Three is a rescue mode
that will allow you to try to manually rescue a system that has problems of some
sort (partition table corruption, boot loader problems, etc.)

I'm not aware of the problem that you orginally had with up2date, so I can't say
exactly what went wrong there, but using the installer to repair that problem
probably wasn't what you wanted to do.  What you most likely wanted to do was to
remove the kernel RPM that up2date installed and install the kernel RPM that
shipped with 7.1.  It is easiest to do that manually, rather than use the
installer.  
At this point, I would say that your best bet is to reinstall the same way that
you did the first time.  I would report the bug you saw with up2date (perhaps
you have already) so that it can be fixed.
Comment 2 Richard Gugeler 2001-10-19 18:07:24 EDT
Thank you for the additional information.

Actually, since I unchecked the "Format" boxes for everything except /boot, 
my / (root), /home and /opt directories were still there.  (Not any more, of 
course, since I just wiped my drive and started over so I could fix the up2date 
problem. Wasn't having any luck with tech support.)  I did, btw, report the 
up2date problem, especially since I noticed I wasn't the only one who had the 
same problem.

Anyway, I'd suggest re-opening this bug and classifying it as insufficient 
information being provided.  Your clear description should be added to the 
information which is displayed in the left-hand panel of the installation 
screen.





Note You need to log in before you can comment on or make changes to this bug.