Bug 54777 - Dual boot (Linux on both images) install fails on RHL7.2
Dual boot (Linux on both images) install fails on RHL7.2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-18 13:18 EDT by Lene Jensen
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 12:37:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lene Jensen 2001-10-18 13:18:56 EDT
Description of problem:
When trying to install a second linux bootable system, Anaconda uses about
1 hour to 
go through "Preparing to install", while sending the following command to
console:
rpmdb: Basenames: unexpected file type or format.
After this, it just hangs

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Linux with an extra partition for a new /
2.After installation change label on /
3.Reboot to attempt new installation on your other /

Actual Results:  Goes through all steps as normal, until you get to
installing packages.
After that, it take a lot longer time to format your new /, then it starts
"preparing to install".  At this point, it took about an hour on a CD
installation.  While this is going on, you can track the error message on
virtual console 1, or it will be desplayed on screen in ftp.  It's
reproducable with CDROM, ftp and nfs. After the initial hour, it just goes
silent, nothing happens

Expected Results:  It should have installed the packages on its root
partition.

Additional info:

This is on RHL 7.2,  the gold version.

My computer is an IBM Thinkpad 600E, PII 400MHz, 192MB, swap 400M, 20G
disk.

I have set it up with sharing /boot and /var.  The second install should
have everything installed on its / (ie. no /usr, /home etc.)
Comment 1 Brent Fox 2001-10-19 17:18:47 EDT
So the first install went ok?
Comment 2 Lene Jensen 2001-10-22 03:51:54 EDT
Yes, the first install has no problems.  I have reinstalled it several times,
and the first installation always works fine.  It is the second install that
doesn't work.
Comment 3 Brent Fox 2001-10-22 21:28:40 EDT
It sounds like the installer is getting confused by the change in partition
labels.  Why was it necessary to change the partition label anyway?  It seems
like you could just do a second install with the remaining space on your hard
drive.  Is this machine in the building and could I watch you duplicate it to
get a better idea of what steps you took?
Comment 4 Lene Jensen 2001-10-23 13:52:14 EDT
Will try as soon as I have time (ie. next week).  And sorry, I'm in England, but
feel free to pop by.  I also thought about the fact that I tried to install it
on /dev/hda8, probably around 12-14 Gb into the disk.  However, it should be
using /boot (/dev/hda1), so that is within the cylinder limit.
Comment 5 Brent Fox 2001-10-23 16:11:55 EDT
Grub may allow you to get around the boot cylinder limitation.  It depends on
the motherboard.
Comment 6 Brent Fox 2001-11-02 10:12:07 EST
Any more info here?
Comment 7 Lene Jensen 2001-11-05 04:18:40 EST
I attempted a reinstall this weekend, and for some reason, it succeeded.  I left
the label to itself (/1, I thought it was /2), and decided _not_ to reinstall
/boot, as I had a lot of stuff in there now.  I also decided to let them share
/var.  It got to the "prepare to install", that took about 15 minutes to go
through, although no activity on the disk nor on the CD.  Then it started the
installation, it took about an hour, compared to an equal installation earlier
taking about 20 minutes.  In the end, I got a working system.

The only difference is that my /dev/hda2 was no longer empty, but contained
Windows, although the second Linux installation was done on /dev/hda8.  Could it
really be that the label was different?
Comment 8 Brent Fox 2001-11-06 17:15:16 EST
I don't know...it's hard to say without having the machine to experiment with. 
Do you want me to close this report since things seem to be working now?
Comment 9 Lene Jensen 2001-11-07 12:37:00 EST
Feel free to close this.  I will not have time to investigate further for
another 2 weeks, if I for some reason find out what is wrong, I will let you
know.
Comment 10 Brent Fox 2001-11-08 15:40:22 EST
Ok.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.