Bug 547805 - [abrt] crash detected in sugar-0.86.3-1.fc12
Summary: [abrt] crash detected in sugar-0.86.3-1.fc12
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a687d91e
: 554430 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-15 18:14 UTC by Mel Chua
Modified: 2010-01-11 18:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-16 18:14:23 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1019 bytes, text/plain)
2009-12-15 18:14 UTC, Mel Chua
no flags Details

Description Mel Chua 2009-12-15 18:14:30 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. Start sugar-emulator.
2. Using the "settings" menu within Sugar, change the color of your avatar.
3. Restart Sugar (as prompted, from within the Sugar GUI).
4. Try to run sugar-emulator again; it will refuse to start.


backtrace
-----
Summary: TBa687d91e sugar-session:81:cleanup_logs:OSError: [Errno 13] Permission denied: '/home/mchua/.sugar/default/logs/1260548317/datastore.log'

Traceback (most recent call last):
  File "/usr/bin/sugar-session", line 252, in <module>
    main()
  File "/usr/bin/sugar-session", line 211, in main
    cleanup_logs()
  File "/usr/bin/sugar-session", line 81, in cleanup_logs
    os.remove(os.path.join(root, f))
OSError: [Errno 13] Permission denied: '/home/mchua/.sugar/default/logs/1260548317/datastore.log'

Local variables in innermost frame:
f: datastore.log
backup_logs: ['datastore.log', 'telepathy-salut.log', 'telepathy-gabble.log', 'shell.log', 'presenceservice.log']
logs_dir: /home/mchua/.sugar/default/logs
path: /home/mchua/.sugar/default/logs/1260548317
backup_dirs: ['/home/mchua/.sugar/default/logs/1260548317', '/home/mchua/.sugar/default/logs/1260548840', '/home/mchua/.sugar/default/logs/1260548907', '/home/mchua/.sugar/default/logs/1260844678']
root: /home/mchua/.sugar/default/logs/1260548317

cmdline: python /usr/bin/sugar-session 
component: sugar
executable: /usr/bin/sugar-session
kernel: 2.6.31.6-166.fc12.i686
package: sugar-0.86.3-1.fc12
uuid: a687d91e

Comment 1 Mel Chua 2009-12-15 18:14:33 UTC
Created attachment 378571 [details]
File: backtrace

Comment 2 Bernie Innocenti 2009-12-16 06:45:00 UTC
Hmm... is /home/mchua/.sugar/default/logs/1260548317/datastore.log really not writable?

Comment 3 Tomeu Vizoso 2009-12-16 10:23:25 UTC
Has Sugar been ran as root? If so, chown -R mchua.mchua ~ should put things straight again.

We should refuse to run as root and write a very clear message, could someone file a bug upstream? Preferably with a patch ;)

Comment 4 Mel Chua 2009-12-16 18:06:29 UTC
Bernie and I talked about this on IRC, and in the middle of our conversation the bug revealed itself as intermittent: log below.

<pre>
07:32:36 < mchua> bernie: interesting - I'm looking at 
                  https://bugzilla.redhat.com/show_bug.cgi?id=547805 and 
                  /home/mchua/.sugar/default/logs/1260548317/datastore.log does 
                  not exist.
07:32:44 < mchua> in fact, /home/mchua/.sugar/default/logs/1260548317 does not 
                  exist
07:32:55 < mchua> so it would logically be unwriteable
07:33:09 < mchua> ...but why the blazes is Sugar trying to write to it in the 
                  first place then?
07:43:33 -!- mvn071 [n=mvn@84e5e70d.math.leidenuniv.nl] has joined #sugar
07:43:35 -!- tinker-f595_ [n=tinker-f@m208-148.dsl.rawbw.com] has joined #sugar
07:43:50 -!- tinker-f595 [n=tinker-f@m208-148.dsl.rawbw.com] has quit [Read 
          error: 54 (Connection reset by peer)]
07:44:23 -!- tinker-f595_ is now known as tinker-f595
07:44:43 -!- Calcifer [n=gdsdfhsd@113.199.171.106] has quit [Remote closed the 
          connection]
07:46:12 < bernie> mchua: how about the containing dir?
07:46:52 < mchua> bernie: /home/mchua/.sugar/default/logs/ exists, and 
                  contains...
07:47:37 < mchua> [mchua@vorpal:~]$ ls /home/mchua/.sugar/default/logs          
                  (12-16 02:47)
07:47:37 < mchua> 1260548907  1260845485           shell.log
07:47:37 < mchua> 1260844678  datastore.log        telepathy-gabble.log
07:47:37 < mchua> 1260844899  presenceservice.log  telepathy-salut.log
07:48:01 < mchua> bernie: so, file does not exist, containing folder does not 
                  exist, containing folder of containing folder does exist.
07:49:02 < bernie> mchua: look where we are: 
                   sugar-session:81:cleanup_logs:OSError
07:49:17 < bernie> mchua: it was trying to cleanup the logs... perhaps removing 
                   the old ones...
07:50:07 < bernie>     """Clean up the log directory, moving old logs into a 
                   numbered backup
07:50:07 < bernie>     directory.  We only keep `_MAX_BACKUP_DIRS` of these 
                   backup directories
07:50:07 < bernie>     around; the rest are removed."""
07:50:26 < mchua> hrm
07:50:46 < bernie> mchua: you have > 3 backup dirs
07:51:24 < mchua> _MAX_BACKUP_DIRS == 3?
07:51:46 < bernie> mchua: the documentation is incorrect... the maximum is 
                   hard-coded as a magic nr.
07:53:58 < bernie> mchua: the algorithm appears sane
07:55:13 < bernie> mchua: it's weird... what happens if you try now?
07:55:51  * mchua tries
07:56:19 < mchua> looks like the same thing, OSError: [Errno 13] Permission 
                  denied: 
                  '/home/mchua/.sugar/default/logs/1260548907/datastore.log
07:56:33 < mchua> wait
07:56:36 < mchua> that exists
07:56:37 < mchua> wtf
07:56:44  * mchua runs sugar-emulator as root
07:57:41 < mchua> bernie: ...and now that worked. buh? I tried it as root 
                  before and it crashed and gave that bug report 3 times.
07:57:58  * mchua shakes fist at intermittent bugs
</pre>

Comment 5 Mel Chua 2009-12-16 18:14:23 UTC
In conclusion:

* This is an intermittent bug we haven't been able to reproduce since.
* An upstream ticket ("Sugar should refuse to run as root user") has been filed at http://dev.sugarlabs.org/ticket/1623.
* This ticket has been closed because it isn't reproducible. (I closed it as INSUFFICIENT_DATA since that seemed the closest to NOT_REPRODUCIBLE, please let me know if it should be something different.)

Comment 6 Tomeu Vizoso 2010-01-11 18:24:59 UTC
*** Bug 554430 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.