Bug 547870 - python as multilib for ppc64?
python as multilib for ppc64?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.4
ppc64 Linux
high Severity low
: rc
: ---
Assigned To: Daniel Mach
Release Test Team
:
Depends On: 488478 609157
Blocks: 526533 625372
  Show dependency treegraph
 
Reported: 2009-12-15 15:53 EST by Jan Kratochvil
Modified: 2011-01-13 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 625372 (view as bug list)
Environment:
Last Closed: 2011-01-13 17:07:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2009-12-15 15:53:51 EST
There is a rebase of GDB (Bug 526533) for RHEL-5.5 to fix various bugs.
There is unrelated new GDB feature - pretty-printing - based on python bindings.

But gdb is supplied as ppc64 and python (.so libraries) only as ppc.
Brew builds gdb.ppc64 depending on python.ppc64 fine as it has all the packages in their ppc64 variant.
But the python.ppc64 dependency is missing on real end-user powerpc system.

Is it easy enough to provide also python.ppc64 - as multilib - or should I rather disable the python support in RHEL-5.5 gdb?
Comment 1 RHEL Product and Program Management 2009-12-15 16:09:42 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 16 Dave Malcolm 2010-09-09 14:49:10 EDT
I'm doing this to Fedora's python.spec in rawhide:
* Thu Sep  9 2010 David Malcolm <dmalcolm@redhat.com> - 2.7-9
- move most of the payload of the core package to the libs subpackage, given
that the libs aren't meaningfully usable without the standard libraries

http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commitdiff;h=2ec5b35c5f46414d8bb1eb5874e3f788967d76e3

Building python-2.7-9.fc15 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2457885
Comment 17 Dave Malcolm 2010-09-09 14:56:03 EDT
(In reply to comment #16)
> I'm doing this to Fedora's python.spec in rawhide:

Similarly for python3.spec in rawhide:
* Thu Sep  9 2010 David Malcolm <dmalcolm@redhat.com> - 3.2-0.4.a1
- move most of the content of the core package to the libs subpackage, given
that the libs aren't meaningfully usable without the standard libraries

http://pkgs.fedoraproject.org/gitweb/?p=python3.git;a=commitdiff;h=26c1be588d2f33c0a44cec2d5c557fdefbc83257

Building python3-3.2-0.4.a1.fc15 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2457903
Comment 21 Daniel Mach 2010-09-21 08:08:44 EDT
$ cd RHEL5.6-Server-20100921.n/5/
$ find -name 'python-libs*'
i386/os/Server/python-libs-2.4.3-32.el5.i386.rpm
ia64/os/Server/python-libs-2.4.3-32.el5.ia64.rpm
ppc/os/Server/python-libs-2.4.3-32.el5.ppc64.rpm
ppc/os/Server/python-libs-2.4.3-32.el5.ppc.rpm
x86_64/os/Server/python-libs-2.4.3-32.el5.x86_64.rpm
s390x/os/Server/python-libs-2.4.3-32.el5.s390x.rpm

it's multilib on ppc only
Comment 23 Alexander Todorov 2010-10-01 09:13:35 EDT
# pwd
/mnt/redhat/rel-eng/RHEL5.6-Server-20100930.0/5

# find -name "python-libs*" | sort
./i386/os/Server/python-libs-2.4.3-32.el5.i386.rpm
./ia64/compatlayer/Server/python-libs-2.4.3-32.el5.i386.rpm
./ia64/os/Server/python-libs-2.4.3-32.el5.ia64.rpm
./ppc/os/Server/python-libs-2.4.3-32.el5.ppc64.rpm
./ppc/os/Server/python-libs-2.4.3-32.el5.ppc.rpm
./s390x/os/Server/python-libs-2.4.3-32.el5.s390x.rpm
./x86_64/os/Server/python-libs-2.4.3-32.el5.x86_64.rpm


Is multilib on ppc and ia64 only. According to comment #0 the request is for ppc. Moving to VERIFIED.
Comment 24 Jan Kratochvil 2010-10-01 12:03:09 EDT
(In reply to comment #23)
> Is multilib on ppc and ia64 only.

Not sure if it was a question.
Multilib is on x86_64, s390x, ppc64(*) and ia64(**).

(*) The whole ppc64 distro with both ppc64 and ppc packages is called "ppc".
(**) From the point of view of this Bug ia64 is not multilib, though.
     ia64 ships also i386 (32bit) packages but those are in a separate
     subdirectory /emul/ia32-linux so /usr/bin/python multilib-sharing is not
     an issue.
Comment 25 Alexander Todorov 2010-10-04 03:42:24 EDT
Hi Jan,
according to comment #23 python-libs is multilib on ppc and ia64 (ia64 has the compatlayer packages). There are no multilib packages for python-libs on x86_64 and s390x. comment #0 requests the multilib change for ppc only, how about s390x and x86_64?
Comment 26 Jan Kratochvil 2010-10-04 11:28:42 EDT
(In reply to comment #25)
> according to comment #23 python-libs is multilib on ppc and ia64 (ia64 has the
> compatlayer packages). There are no multilib packages for python-libs on x86_64
> and s390x. comment #0 requests the multilib change for ppc only, how about
> s390x and x86_64?

This was just an issue for ppc because RHEL-5.5 shipped gdb arch and shipped python arch did not match each other (gdb.ppc64 vs. python.ppc).

RHEL-5.5 x86_64 ships:
gdb-7.0.1-23.el5.x86_64.rpm
python-2.4.3-27.el5.x86_64.rpm
python-devel-2.4.3-27.el5.i386.rpm
python-devel-2.4.3-27.el5.x86_64.rpm
That python-devel.i386 IMO cannot work but that is of no concern to gdb.

RHEL-5.5 s390x ships:
gdb-7.0.1-23.el5.s390x.rpm
python-2.4.3-27.el5.s390x.rpm
python-devel-2.4.3-27.el5.s390.rpm
python-devel-2.4.3-27.el5.s390x.rpm
That python-devel.s390 IMO cannot work but that is of no concern to gdb.

So ppc/ppc64 is the only python change required for python support for gdb on RHEL-5.x.
Comment 27 Alexander Todorov 2010-10-04 13:33:40 EDT
Thanks for clarification Jan. No need to change bug status, stays in VERIFIED.
Comment 29 errata-xmlrpc 2011-01-13 17:07:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0020.html

Note You need to log in before you can comment on or make changes to this bug.