Bug 54788 - xcdroast spawns unkillable cdda2wav
xcdroast spawns unkillable cdda2wav
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-18 19:12 EDT by Kirk
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-22 04:40:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirk 2001-10-18 19:12:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
When I run xcdroast, most times, but not all, When hitting the 'duplicate'
or 'master' button, xcdroast freezes and slowly eats up all of the
resources so that it has to be restart via ssh and another terminal.

I have updated to the latest xcdroast and companions in rawhide, but the
problem still happens...it seems to happen when the system has been running
awhile, because it will normally run okay after a reset.  The only
noticeable syslog messages refer to a missing char-major-97, but I also see
this when I succesfully burn cd's.  I'm not sure what logs you need, but
I'll be glad to send anything you need.

Note that after this happens, running cdrecord -scanbus produces nothing
and must be exited with control-c

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Start xcdroast (I su to root before)
2.Hit 'duplicate' or 'master'
3.
	

Actual Results:  system locked up

Expected Results:  it should have read the cd and displayed the tracks. 
Happens on blank cd's or stamped cd's	

Additional info:

using latest stable alsa drivers on a via686a
have a philipps PCRW80 using scsi-emulation...its the only drive on the
secondary IDE channel.
using kernel 2.4.3.12 (downloading the update to 2.4.9 now)
uging the latest xcdroast-cdrecord-mkisofs-cdda2wav from rawhide
Comment 1 Tim Waugh 2001-10-19 08:15:13 EDT
I need you to be more specific about some things.  I had a go at reproducing 
this but didn't see any bad effects.

Is the blank CD in the input tray? (That's what I tried.)

By 'system locked up', do you mean that the entire machine froze?  I'm 
guessing not from your other comments.  In that case, please show me the 
output of 'ps axfwww' when xcdroast gets into this state.

Let me know the result of trying kernel 2.4.9-6.  Thanks.
Comment 2 Kirk 2001-10-21 23:48:45 EDT
Well, this seems to have been cured with the 2.4.9 kernel...I've tried all of
the usual tricks, but it just seems to work now.  If it happens again, I'll
reopen or file another bug with your suggested output.  Thanks!
Comment 3 Tim Waugh 2001-10-22 04:39:54 EDT
Okay, great.

Note You need to log in before you can comment on or make changes to this bug.