Bug 54790 - BuildRequires needed in gnome-applets-1.4.0.1-6.src.rpm
Summary: BuildRequires needed in gnome-applets-1.4.0.1-6.src.rpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-applets   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-19 00:01 UTC by R P Herrold
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-19 14:06:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2001-10-19 00:01:31 UTC
gnome-applets-1.4.0.1-6.src.rpm

hmmm ... a BuildRequires: is needed for apmd to get rid of 
the shell script missing dependency detection ...

Add:

BuildRequires: apmd

to the .SPEC file

Subject: ORCprospector 0.01-011017 -- gnome-applets
    gnome-applets-1.4.0.1-6.src.rpm

gnome-applets   gnome-applets-1.4.0.1-6.src.rpm
/var/ftp/./pub/mirror/redhat/rawhide/SRPMS/gnome-applets-1.4.0.1-6.src.rpm
=================================

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.11236
You must have apmd installed

Comment 1 Havoc Pennington 2001-10-19 14:58:02 UTC
The problem is that apmd is only required/present on i386, and rpm doesn't
support per-architecture BuildRequires. So if it required apmd, it wouldn't
build on alpha/ia64/etc. Thus the %prep phase has a manual check for 
apmd on i386.

%ifnarch %{no_apm_archs}
%setup -q -a 5

if ! test -e /usr/lib/libapm.a ; then
    echo "You must have apmd installed"
    exit 1
fi

%else
%setup -q
%endif

You could imagine hacking rpm to fix this, of course, but can't be fixed in 
gnome-applets, and not sure it's worth the complexity/breakage in rpm.

Comment 2 R P Herrold 2001-10-26 00:55:06 UTC
OK by me -- Thanks -- This is interesting so I will 'mention' it to JBJ



Note You need to log in before you can comment on or make changes to this bug.