Bug 547931 - SELinux is preventing /usr/libexec/gdm-session-worker "read write" access on /root.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "read write" access on ...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:de886bb5ac6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-16 01:44 UTC by efreeti
Modified: 2009-12-16 13:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-16 13:55:06 UTC


Attachments (Terms of Use)

Description efreeti 2009-12-16 01:44:49 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "read write" access on
/root.

Detailed Description:

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.1-25.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.32-55.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7
                              21:25:57 EST 2009 i686 i686
Alert Count                   1
First Seen                    Wed 16 Dec 2009 12:11:20 AM MYT
Last Seen                     Wed 16 Dec 2009 12:11:20 AM MYT
Local ID                      7dcf5a71-35ab-487a-99a7-c3fcfe76810f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1260893480.390:12127): avc:  denied  { read write } for  pid=18996 comm="gdm-session-wor" name="root" dev=sda1 ino=98113 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1260893480.390:12127): arch=40000003 syscall=33 success=no exit=-13 a0=8a21368 a1=7 a2=1f81a4 a3=8a7ddf8 items=0 ppid=18908 pid=18996 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=18 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-55.fc12,catchall,gdm-session-wor,xdm_t,admin_home_t,dir,read,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:dir { read write };

Comment 1 Daniel Walsh 2009-12-16 13:55:06 UTC

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.