Bug 54794 - grubby ignores "fallback" setting
Summary: grubby ignores "fallback" setting
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-19 03:52 UTC by Michael Schwendt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-29 19:57:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2001-10-19 03:52:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The kernel rpm's new-kernel-pkg script uses "grubby" to add a new boot
entry to /boot/grub/grub.conf. It inserts a new entry 0 at the beginning,
but doesn't update the "fallback=" setting accordingly.

Example:

# before kernel package update
default=0
fallback=1

# after kernel package update
default=1
fallback=1

Version-Release number of selected component (if applicable):
grub-0.90-11.i386.rpm from Raw Hide


How reproducible:
Always

Steps to Reproduce:
1. cp /boot/grub/grub.conf /boot/grub/grub.conf.old
2. grubby --copy-default --title "test" --add-kernel /boot/vmlinuz-2.4.9-6
/boot/initrd-2.4.9-6.img
3. diff -u /boot/grub/grub.conf.old /boot/grub/grub.conf



Actual Results:  Grubby inserted the new kernel as first entry (0) and
increased the "default=" value accordingly to keep loading the old default
boot entry, but it did NOT increase the "fallback=" value.

Expected Results:  Grubby should have increased the "fallback=" value, too,
because it has inserted a new boot entry at the beginning.

Additional info:

[My main system is a fully updated Seawolf with just a few packages from
Raw Hide to get ext3. When I made the most recent kernel update for Seawolf
and since I have GRUB as boot loader, the kernel package's post-install
script added the 2.4.9-6 kernel using /sbin/new-kernel-pkg which in turn
runs grubby to modify /boot/grub/grub.conf.]

Comment 1 Michael Schwendt 2001-10-19 04:16:33 UTC
Wrong component. Changing to mkinitrd-3.2.6-1.

Comment 2 Michael Schwendt 2001-10-19 05:46:08 UTC
The equal signs (=) for "default" and "fallback" values in this report are type
errors. Imagine they
would not be there.

Comment 3 Erik Troan 2002-05-22 02:43:44 UTC
added for mkinitrd 3.4 (still being developed)


Note You need to log in before you can comment on or make changes to this bug.