Bug 54796 - Less has problem chopping long lines and with 8-bit characters
Summary: Less has problem chopping long lines and with 8-bit characters
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: less   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-19 08:09 UTC by Dmitry Bolkhovityanov
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 12:21:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitry Bolkhovityanov 2001-10-19 08:09:41 UTC
All applies to less-358-21 from RawHide, but the same problems were in
358-16 from 7.1.

Description of Problem:

I. Less doesn't correctly chop long lines (the '-S' key command). This
happens regardless of locale -- I've tried ru_RU.KOI8-R and en_US.  Instead
of chopping characters after column 80, it still displays them, itself not
knowing about it.

II. Less doesn't input 8-bit characters in e.g. "search" prompt.

Version-Release number of selected component (if applicable):
358-1

How Reproducible:
100%

I.
Steps to Reproduce:
1. Run "man Core" (requires appropriate openmotif-devel to be installed;
any other man page with wide tables would suffice), scroll it to the wide
table.
2. Press '-S' to set "chop long lines" mode, and any other key for it to
take effect.

Actual Results:
The table after column 80 is still displayed, "overlaying" the normal
content.

Expected Results:
Right part of the table should be chopped.

II.
Steps to reproduce:
1. Set locale to something 8-bit/singlebyte (e.g. ru_RU.KOI8-R).
2. Run less (e.g. "less /etc/passwd").
3. Press "/" to get search prompt and try to input some russian characters.

Actual Results:
Instead of inputting the letters, "less" acts strange: it delays displaying
until next letter is pressed (as if it treates the first one as a dead
key); than it displays both of them with 8-th bit cleared (thus russian
letters convert to latin of opposite case).

Expected Results:
The keys entered should be displayed.

Additional Information:
The problem seems to be in the japanese patch.  It is worth removing that
patch (less-358+iso247*.diff) from non-japanese Red Hat Linux
distributions.

Comment 1 Karsten Hopp 2003-01-30 12:21:58 UTC
I got a patch in bug #79977 for the current less version which also fixes this bug. 


Note You need to log in before you can comment on or make changes to this bug.