Bug 547962 - [nautilus][duplicate] - Search stops upon encountering an unreadable directory -- Patch not included [NEEDINFO]
[nautilus][duplicate] - Search stops upon encountering an unreadable director...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nautilus (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Alexander Larsson
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 00:58 EST by Satyabrata Maitra
Modified: 2014-06-02 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pm-rhel: needinfo? (smaitra)


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2009-12-16 00:58:24 EST
Description of problem:
Unable to search for "/var" using nautilus search, as search stops when certain files in "/" are not readable.
some files aren't found if there is a directory in the hierarchy that isn't
readable.
Actually this bug having a joint issue with gmone-vfs2 component also. The gnome-vfs2 part has been fixed in the following rpm of gnome-vfs2, and the reference of this bug is also given below. The nautilus part is also fixed, but its still remains as a patch, which need to be included with the nautilus package and release with the fix.
Request to apply the patch mentioned below, to the nautilus package to fix the issue.

Proposed Patch Link - 
http://svn.gnome.org/viewvc/nautilus/trunk/test/test-nautilus-search-engine.c?r1=11900&r2=13708

Reference bugs :
https://bugzilla.redhat.com/show_bug.cgi?id=432764

Reference bug for gnome bugzilla :

https://bugzilla.gnome.org/show_bug.cgi?id=433105
https://bugzilla.gnome.org/show_bug.cgi?id=515031

Version-Release number of selected component (if applicable):
nautilus-2.16.2-7.el5
gnome-vfs2-2.16.2-5.el5 
gnome-vfs2-devel-2.16.2-5.el5 
gnome-vfs2-debuginfo-2.16.2-5.el5 
gnome-vfs2-smb-2.16.2-5.el5

How reproducible:
Always.

Steps to Reproduce:
1. Open nautilus
2. Ctrl+F to open search window
3. Search for var using "/"

OR

Steps to reproduce:
1. mkdir ~/tdir
2. chmod a-r ~/tdir
3. ls -l -U
4. search for a file that exists after ~/tdir in the list
  -or-
   search for a file that exists in a subdirectory that exists after ~/tdir in
the list.
  
Actual results:
/var is never found or the file is not found.

Expected results:
Desired files to be found.

Additional info:
Comment 1 RHEL Product and Program Management 2014-03-07 08:56:45 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:23:45 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.