Bug 54797 - With gtk+-1.2.10-11.i386.rpm package characters from other than iso-8859-1 sets are shown in wrong way
With gtk+-1.2.10-11.i386.rpm package characters from other than iso-8859-1 se...
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: gtk+ (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-19 06:14 EDT by Olaf Fraczyk
Modified: 2007-03-26 23:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-13 10:20:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source code explaining bug (1.69 KB, text/plain)
2001-10-19 06:24 EDT, Olaf Fraczyk
no flags Details

  None (edit)
Description Olaf Fraczyk 2001-10-19 06:14:05 EDT
Description of Problem:
Labels with iso-8859-2 characters are not shown at all, if we don't
initialise locale in gtk program.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-11.i386.rpm

How Reproducible:
every time

Steps to Reproduce:
1. Compile attached source code

Actual Results:
Labels with iso-8859-2 characters are not shown at all

Expected Results:
Labels shown correctly.

Additional Information:
This bug is not observed in other gtk+-1.2.10 (made self, and from other
vendors e.g. ximian)
Also, in previous version of gtk+ shipped by redhat it was shown correctly
(tested for 1.2.8 and below - 1.2.9 - not tested)
Comment 1 Olaf Fraczyk 2001-10-19 06:24:21 EDT
Created attachment 34401 [details]
source code explaining bug
Comment 2 Owen Taylor 2001-10-19 11:07:47 EDT
It's not a bug. If you haven't initialized localized operation
you can't expect localized operation to work. :-)

If you want to reproduce the behavior from the tarball, you probably
need to compile passing the --with-native-locale flag, which
uses the native libc locale conversion code rather than
slow, inefficient, unreliable emulation done through Xlib.
Comment 3 Olaf Fraczyk 2001-11-13 10:20:06 EST
So the 'native libc conversion code' is more buggy ;)
Even if you initialise locale operation, the problem remains for:
locale set to "POSIX", and "C".
So it is needed to:
1. fix glibc
or
2. use "low, inefficient, unreliable emulation done through Xlib."

Regards,

Olaf
Comment 4 Owen Taylor 2001-11-13 11:19:51 EST
How would you expect your program to know that the high characters
in the POSIX or C locale are iso-8859-2? How does it know that
they aren't iso-8859-1, UTF-8, etc?

style->font only tells GTK+ what to use to display the string; it
still needs to know how to manipulate it before it gets to that
point. And if the locale is C or POSIX, either because gtk_set_locale()
hasn't been called or because that's the user's locale, then the
only thing it can manipulate is ASCII.

Note You need to log in before you can comment on or make changes to this bug.