This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 547993 - Package Name Change: jconvolver - Real-time Convolution Engine
Package Name Change: jconvolver - Real-time Convolution Engine
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 04:50 EST by Orcan Ogetbil
Modified: 2010-02-09 00:01 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.8.4-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-24 09:27:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)
diff between the old and the new spec files (2.99 KB, patch)
2009-12-16 04:52 EST, Orcan Ogetbil
no flags Details | Diff

  None (edit)
Description Orcan Ogetbil 2009-12-16 04:50:14 EST
Spec URL: http://oget.fedorapeople.org/review/jconvolver.spec
SRPM URL: http://oget.fedorapeople.org/review/jconvolver-0.8.4-1.fc12.src.rpm
Description: 
Jconvolver is a real-time convolution engine. It can execute up to a 64 by 64
convolution matrix (i.e. 4096 simultaneous convolutions) as long as your CPU(s)
can handle the load. It is designed to be efficient also for sparse (e.g.
diagonal) matrices. Unused matrix elements do not take any CPY time.


This software changed its name from jconv to jconvolver. I am CCing the original reviewer Mattias in case he wants to re-review it. It should be a smooth re-review since not much has changed since the original review. I am also attaching the diff between the approved version of the jconv's spec file and this new spec file.
Comment 1 Orcan Ogetbil 2009-12-16 04:52:04 EST
Created attachment 378722 [details]
diff between the old and the new spec files

Attaching the diff between the old and the new spec files
Comment 2 Orcan Ogetbil 2009-12-16 04:54:00 EST
CC'ing the original reviewer. Mattias, you can remove yourself from the CC if you do not wish to re-review this.
Comment 3 Orcan Ogetbil 2009-12-19 19:04:48 EST
Of course anyone else can review it too. 

Note that we have a broken dependency (zita-convolver/jconv) in the rawhide tree because this package is missing for the time being. It would be good to have this package reviewed before F-13 is out.
Comment 4 Mamoru TASAKA 2009-12-20 11:40:51 EST
Well,

? About Source1:
  - I checked http://www.kokkinizita.net/linuxaudio/downloads/index.html ,
    however the license of Source1 seems unclear. Would you ask upstream?

  - While Source0 is 128K, Source1 has 6.0M (50 times the size of Source1)
    and as a result while jconvolver binary rpm has 6.4M its debuginfo rpm
    has only 48K.
    Is Source2 always needed for jconvolver? Also are there any reason
    behind that jconvolver and -reverbs are not seperately packaged (into
    rpm)?
Comment 5 Orcan Ogetbil 2009-12-20 17:20:39 EST
Thanks Mtasaka,

(In reply to comment #4)
> Well,
> 
> ? About Source1:
>   - I checked http://www.kokkinizita.net/linuxaudio/downloads/index.html ,
>     however the license of Source1 seems unclear. Would you ask upstream?
> 

Sure. I just asked upstream via email.

>   - While Source0 is 128K, Source1 has 6.0M (50 times the size of Source1)
>     and as a result while jconvolver binary rpm has 6.4M its debuginfo rpm
>     has only 48K.
>     Is Source2 always needed for jconvolver? Also are there any reason
>     behind that jconvolver and -reverbs are not seperately packaged (into
>     rpm)?  

Ah, this is the way we used to package jconv. It is a "packager's choice" in some sense. Let me elaborate:

Imagine that you are packaging an office package. The office software makes use of fonts that are under a special format that can only be opened from this particular office software. Of course the software can operate without these fonts but it is 50 times more functional if it these fonts were available. :)

It is almost the same situation with jconv(olver). We can put these in a subpackage. But given the target audience is really limited to enthusiasts and these reverbs aren't updated independently from jconv(olver) software, it is not beneficial to make a subpackage (or a separate package).

This package came from PlanetCCRMA. We didn't receive any user complaints about the size all this time either here or at PlanetCCRMA list. Therefore I decided to keep things the way they were for consistency.
Comment 6 Mamoru TASAKA 2009-12-21 13:07:04 EST
(Well, it is better that you don't compare to font packages.
 Now Fedora has extra guidelines for font packages and bundling
 fonts in this way is _strictly_ forbidden and will surely be
 rejected ...
 https://fedoraproject.org/wiki/Packaging:FontsPolicy
)

Still I don't understand.
(In reply to comment #5)
> Imagine that you are packaging an office package. The office software makes use
> of fonts that are under a special format that can only be opened from this
> particular office software. Of course the software can operate without these
> fonts but it is 50 times more functional if it these fonts were available. :)

- Well, how is it different from that "xscreensaver can be used
  with xscreensaver-base only but installing xscreensaver-extras
  or xscreensaver-gl-extras makes much better" (I guess people
  using xscreensaver-base usually also installs xscreensaver-extras),
  or "firefox can be used only with it but installing plugin foo or
  bar makes it much better"?

  Seperating source (or at least creating subpackages)
  has some advantages
  - You don't have to update seperated subpackage when you
    apply some patches against main package
  - Fedora already support noarch subpackage
  - Source1 may have different license (as it is rather contents
    package) (or license may change) and seperating it can make it 
    easier to keep track of licensing issue

> It is almost the same situation with jconv(olver). We can put these in a
> subpackage. But given the target audience is really limited to enthusiasts and
> these reverbs aren't updated independently from jconv(olver) software, it is
> not beneficial to make a subpackage (or a separate package).
Comment 7 Mamoru TASAKA 2009-12-21 13:12:17 EST
(Well, I may be asking you some malicious question, however I
 still think that bundling 50 times larger package into
 the main package which you are saying is not strictly needed
 is not good)
Comment 8 Orcan Ogetbil 2009-12-22 09:17:50 EST
Hi,
I know "fonts" is not the best example. That's why I tried to emphasize that they were imaginary "special" fonts. Oh well... 

I still didn't get a response from the author. I'm removing the reverbs for now. I'll re-add them once the license is cleared up.

Spec URL: http://oget.fedorapeople.org/review/jconvolver.spec
SRPM URL: http://oget.fedorapeople.org/review/jconvolver-0.8.4-2.fc12.src.rpm


>   - You don't have to update seperated subpackage when you
>     apply some patches against main package

This is no big problem since we have deltarpms now :)

As I said this is my choice. If there were multiple possible "plugins" available then I would probably not bundle any of them. But there is only 1 available in this case. And this was the way this has been packaged for a while, even before I took over the package. I assume that people using this software expect the reverbs to be there by now.
Comment 9 Mamoru TASAKA 2009-12-23 12:25:09 EST
Well for SOURCE1, I leave it to your choise how to package it
(however please make upstream clarify the license first)

-------------------------------------------------------
  This package (jconvolver) is APPROVED by mtasaka
-------------------------------------------------------
Comment 10 Orcan Ogetbil 2009-12-23 15:24:42 EST
Thanks! I won't add it until the license is cleared.

New Package CVS Request
=======================
Package Name: jconvolver
Short Description: Real-time Convolution Engine
Owners: oget nando
Branches: F-11 F-12
InitialCC:
Comment 11 Kevin Fenzi 2009-12-24 01:58:10 EST
cvs done.
Comment 12 Mamoru TASAKA 2010-01-05 00:52:52 EST
Would you rebuild this package also on F-11/12 (as you
requested to add these branches) and submit push requests
on bodhi?
Comment 13 Mamoru TASAKA 2010-01-13 11:22:37 EST
ping?
Comment 14 Orcan Ogetbil 2010-01-21 08:45:30 EST
Hi Mamoru,
Sorry I was away for about a month (I was in the away list in the wiki though). I will get back to this soon, possibly this weekend.
Comment 15 Fedora Update System 2010-01-22 08:09:35 EST
jconvolver-0.8.4-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/jconvolver-0.8.4-2.fc12
Comment 16 Fedora Update System 2010-01-22 08:10:08 EST
jconvolver-0.8.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/jconvolver-0.8.4-2.fc11
Comment 17 Mamoru TASAKA 2010-01-24 09:27:24 EST
Closing.
Comment 18 Fedora Update System 2010-02-08 23:59:23 EST
jconvolver-0.8.4-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-02-09 00:01:01 EST
jconvolver-0.8.4-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.