Bug 548121 - /sbin/udevsettle symlink should be removed
/sbin/udevsettle symlink should be removed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 12:25 EST by Richard W.M. Jones
Modified: 2010-03-05 16:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-05 16:30:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-12-16 12:25:05 EST
Description of problem:

The old udevsettle command in Fedora 12 reported that it was
deprecated in favour of "udevadm settle".

In current Rawhide, /sbin/udevsettle still exists but is now
completely non-functional.  It prints:

/sbin/udevsettle
missing or unknown command

Since it is no longer useful, this symlink should be "rm"'d
in the %install phase of our spec file (or else replaced with
a script / link that actually does work, but I favour just
nuking it).

Version-Release number of selected component (if applicable):

udev.x86_64 0:147-2.fc13

How reproducible:

Always.

Steps to Reproduce:
1. Run /sbin/udevsettle.
2.
3.
  
Actual results:

Prints an error message.

Expected results:

Should work, or even better, not exist at all.

Additional info:
Comment 1 Charles R. Anderson 2010-03-05 16:30:27 EST
I see that the symlink has been fixed:

udev-151-3.fc13.x86_64

Note You need to log in before you can comment on or make changes to this bug.