Bug 548167 - SELinux is preventing /usr/sbin/NetworkManager "read" access on \x2fdevices\x2fpci0000:00\x2f0000:00:1c.4\x2f0000:06:00.0\x2fnet\x2feth0.
SELinux is preventing /usr/sbin/NetworkManager "read" access on \x2fdevices\x...
Status: CLOSED DUPLICATE of bug 548169
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:c82c6b21504...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 15:06 EST by mrblack
Modified: 2009-12-16 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 17:13:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mrblack 2009-12-16 15:06:47 EST
Résumé:

SELinux is preventing /usr/sbin/NetworkManager "read" access on
\x2fdevices\x2fpci0000:00\x2f0000:00:1c.4\x2f0000:06:00.0\x2fnet\x2feth0.

Description détaillée:

[SELinux est en mode permissif. Cet accès n'a pas été refusé.]

SELinux denied access requested by NetworkManager. It is not expected that this
access is required by NetworkManager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Autoriser l'accès:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Informations complémentaires:

Contexte source               system_u:system_r:NetworkManager_t:s0
Contexte cible                system_u:object_r:device_t:s0
Objets du contexte            \x2fdevices\x2fpci0000:00\x2f0000:00:1c.4\x2f0000:
                              06:00.0\x2fnet\x2feth0 [ file ]
source                        NetworkManager
Chemin de la source           /usr/sbin/NetworkManager
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         NetworkManager-0.7.996-7.git20091113.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.32-56.fc12
Selinux activé               True
Type de politique             targeted
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.31.6-166.fc12.i686.PAE #1
                              SMP Wed Dec 9 11:00:30 EST 2009 i686 i686
Compteur d'alertes            2
Première alerte              mer 16 déc 2009 20:58:30 CET
Dernière alerte              mer 16 déc 2009 20:58:30 CET
ID local                      02efd26a-240c-4ba5-ba85-3f84c7384c24
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1260993510.184:32): avc:  denied  { read } for  pid=1441 comm="NetworkManager" name="\x2fdevices\x2fpci0000:00\x2f0000:00:1c.4\x2f0000:06:00.0\x2fnet\x2feth0" dev=tmpfs ino=9346 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1260993510.184:32): avc:  denied  { open } for  pid=1441 comm="NetworkManager" name="\x2fdevices\x2fpci0000:00\x2f0000:00:1c.4\x2f0000:06:00.0\x2fnet\x2feth0" dev=tmpfs ino=9346 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1260993510.184:32): arch=40000003 syscall=5 success=yes exit=12 a0=bfe0b2dc a1=8000 a2=1b6 a3=7f83d98 items=0 ppid=1 pid=1441 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-56.fc12,catchall,NetworkManager,NetworkManager_t,device_t,file,read
audit2allow suggests:

#============= NetworkManager_t ==============
allow NetworkManager_t device_t:file { read open };
Comment 1 Daniel Walsh 2009-12-16 17:13:20 EST

*** This bug has been marked as a duplicate of bug 548169 ***

Note You need to log in before you can comment on or make changes to this bug.