Bug 54819 - PXE won't work with over 2Gb of RAM
PXE won't work with over 2Gb of RAM
Status: CLOSED DUPLICATE of bug 63945
Product: Red Hat Linux
Classification: Retired
Component: pxe (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-19 14:24 EDT by shelley palmer
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 06:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shelley palmer 2001-10-19 14:24:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
 The problem occurs with the pxe-0.1-22 package that comes with RedHat.
The package contain the sources for building linux.0 (PXE stage 0 boot 
loader).  The linux.0 bootloader downloads the linux.1 (linux kernel 
image) file at memory address 3Mb, but downloads the ramdisk image 
(linux.2) at top of memory - 4Mb.  The linux kernel boots fine, but on 
systems with > 2Gb RAM, the ramdisk image in memory is getting 
overwritten, and the linux kernel panics when attempting to mount the 
ramdisk.  I have fixed this by loading the ramdisk at a lower memory 
address (5Mb, changing initrd_addr in pxe-linux/nbp-linux/download.c to 5 
* 1024L * 1024 instead of top of mem).  Another fix that may work but I 
haven't tried yet is decreasing the memory size via the command line 
passed to the linux kernel by 4Mb.  Will my fix cause other problems?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use server built with 4 Gb RAM and RH Linux 7.1
2.Configure to boot from PXE
3.Download Ramdisk image to server
	

Actual Results:  The linux kernel boots fine, but on systems with > 2Gb 
RAM, the ramdisk image in memory is getting overwritten, and the linux 
kernel panics when attempting to mount the ramdisk. 

Expected Results:  Should load Ramdisk

Additional info:
Comment 1 Seth Vidal 2001-12-07 14:53:05 EST
I tried your change to pxe-linux's download.c for the linux.0. On a dual athlon
using tyan tiger 2460 motherboard. It changes it in weird ways, notably the
system hangs at:
Uncompressing Linux... Ok, Booting the kernel.

then it just hangs - occasionally it will reboot after a while.

no other effect.

However, When I drop the memory to 512M and I take out that change the system
boots fine from pxe but two things happen:

1. the kernel parameters passed from pxe are overwritten/garbled
2. the ide hard drive errors and won't format

if I boot it from a floppy disk all works well.
its quite baffling but appears to be clearly related to the pxe loader (linux.0)
in the build tree of the rpm.

Any ideas on where to go for an update to this tree or for more information?

thanks

Comment 2 Seth Vidal 2001-12-18 23:16:24 EST
I can fix most of these problems by using the pxelinux bootstrap from a more
recent pxelinux.

the problems just vanish at that point.

Also updating the 3com mba rom to 4.30 doesn't hurt things and gives you more
verbose information on the screen
Comment 3 Elliot Lee 2002-06-21 13:21:08 EDT

*** This bug has been marked as a duplicate of 63945 ***

Note You need to log in before you can comment on or make changes to this bug.