Bug 548195 - kpackagekit crashes: symbol lookup error
kpackagekit crashes: symbol lookup error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 16:16 EST by Martin Kho
Modified: 2009-12-25 09:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-23 04:58:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
KDED4 crash report (4.66 KB, text/plain)
2009-12-24 17:30 EST, Martin Kho
no flags Details
kpackagekitsmarticon crash report (4.19 KB, text/plain)
2009-12-24 17:31 EST, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2009-12-16 16:16:44 EST
Description of problem:
Running kpackagekit from within System Settings or stand alone it crashes with the message:

/usr/bin/kpackagekit: symbol lookup error: /usr/lib64/kde4/kcm_kpk_settings.so: undefined symbol: _ZN10PackageKit6Client10getActionsEv

Version-Release number of selected component (if applicable):
* kpackagekit-0.5.1.1-1.fc13.x86_64
* kde version 4.3.80-4

How reproducible:
Start kpackegekit from the command line.
  
Actual results:
kpackagekit crashes with the above error message

Expected results:
kpackagekit starts

Additional info:
If I can remember right this error is introduced after the kde update from 4.3.75 to 4.3.80. Tried running kpackagekit in gdb, but this didn't give any additional information.
Comment 1 Kevin Kofler 2009-12-16 16:37:04 EST
This is due to KPackageKit 0.5.1.1 not being compatible with the latest PackageKit. We need to build 0.5.2 for Rawhide too.
Comment 2 Martin Kho 2009-12-16 17:04:54 EST
Thanks for the info, Kevin.

The incompatibility was already known, so I spammed bugzilla (again) :-)

Sorry for that.

This report can be closed?

Martin Kho
Comment 3 Kevin Kofler 2009-12-16 17:10:48 EST
Let's only close it once the problem is actually fixed.
Comment 4 Kevin Kofler 2009-12-23 04:58:56 EST
Rex Dieter built KPackageKit 0.5.2 for Rawhide.
Comment 5 Martin Kho 2009-12-24 17:30:24 EST
Hi,

KPackageKit-0.5.2 crashed ;-( What did I do?

1. Open System Setting -> Add and Remove Software -> Software Updates
2. Press button Refresh

KDED4 and KPackagekitsmarticon crashed.

KCrash reports: see comment #6 and #7

Do I have to report these at bugzilla.kde.org?


Martin Kho
Comment 6 Martin Kho 2009-12-24 17:30:59 EST
Created attachment 380249 [details]
KDED4 crash report
Comment 7 Martin Kho 2009-12-24 17:31:45 EST
Created attachment 380250 [details]
kpackagekitsmarticon crash report
Comment 8 Kevin Kofler 2009-12-25 09:47:01 EST
Separate reports for separate issues please! This new crash is completely different.

Note You need to log in before you can comment on or make changes to this bug.