Bug 5482 - isapnp tools reports errors incorrectly on Intel EtherExpress 10+ ISA card
isapnp tools reports errors incorrectly on Intel EtherExpress 10+ ISA card
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: isapnptools (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-03 14:26 EDT by margarita
Modified: 2014-03-16 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-01 13:54:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description margarita 1999-10-03 14:26:27 EDT
Red hat 6.0 wouldn't recogonize the athome's ISA cable modem

I used isapnptools to configure the card. It was not clear
from the documentation which to configure (The IRQ or the
board address) I went back to WIN95 and wrote down all
the configuratiomn parameters. On my old IWILL motherboard
I configured just the IRQ OK.

The new faster moutherboard would not work with this
configureation.

After reinstalling the system about 30 times I found out
that the only way that worked was to configue the board
with the address from WIN95. The system hung every time
an attempt was made to configue eth0 with the IRQ and
isapnp did not complain.


Finally I found out that I needed to configure the board
address at 0x210  and change the fatal messages to warning
so that it would complete. I am sure that there was no
resource conflict that isapnp reported because I checked
all the resources that Red Hat had configured.

Some error is in the resource.c file.
Comment 1 Bill Nottingham 1999-10-04 11:20:59 EDT
isapnptools has a couple of bugs with I/O addresses. Try grabbing
the latest isapnptools from Raw Hide
(ftp://ftp.redhat.com/pub/rawhide/) - does that solve the problem?
Comment 2 margarita 1999-10-20 13:54:59 EDT
This isa ethernet card supplied by athome is causing severe problems.
There is no good documentation on the configuration of a cable modem
on an ISA card. The documentation that exists is not complete and does
not give a procedure on the complete configuration. The information is
fragmented. The worst part of the configuration is when the system is
rebooted and it hangs on configuration of eth0. Usually a complete
install is necessary because this particular "hang" damages the
root filesystem so badly that recovery is not possible with fsck
under any circumstances.

I found out by trial and error that configurating the port address
(derived from windows - Ugh) and not the IRQ with isapnp works if
the fatal errors are downgraded to warnings.
Comment 3 Bill Nottingham 1999-10-20 13:57:59 EDT
Did you try the updated isapnptools?
Comment 4 margarita 1999-10-20 16:26:59 EDT
I did try the newer tools but they did not do any better than the
older one. The listing below is the file that works. After all other
parameters have been entered in the control panel and linuxconf the
command "/sbin/isapnp /etc/isapnp.conf" will verify that the card
is recogonized. I do "ifconfig" to verify that eth0 is active and
then reboot. I have reinstalled so many times, I can do it in my
sleep. I just refuse to give up because I want this system to work.

In the long run, I intend to get another motherboard with 5 pci
cards and replace this turkey isa card with the EtherExpress 100
pci which the system will recogonize without isapnp. That card
will adjust the speed automatically to 10 megabits per second.

In the meantime I have archived the file that works.

*********************************************************
# $Id: pnpdump.c,v 1.18 1999/02/14 22:47:18 fox Exp $
# This is free software, see the sources for details.
# This software has NO WARRANTY, use at your OWN RISK
#
# For details of this file format, see isapnp.conf(5)
#
# For latest information and FAQ on isapnp and pnpdump see:
# http://www.roestock.demon.co.uk/isapnptools/
#
# Compiler flags: -DREALTIME -DNEEDSETSCHEDULER -DABORT_ONRESERR
#
# Trying port address 0203
# Board 1 has serial identifier ef c9 a6 1f 36 31 10 d4 25

(DEBUG)
(READPORT 0x0203)
(ISOLATE PRESERVE)
(IDENTIFY *)
(VERBOSITY 2)
(CONFLICT (IO WARNING)(IRQ WARNING)(DMA WARNING)(MEM WARNING)) # or
WARNINGING

# Card 1: (serial identifier ef c9 a6 1f 36 31 10 d4 25)
# Vendor Id INT1031, Serial Number 3383107382, checksum 0xEF.
# Version 1.0, Vendor version 0.0
# ANSI string -->Intel PRO/10+ or compatible adapter<--
#
# Logical device id INT1031
#     Device support I/O range check register
#     Device supports vendor reserved register @ 0x38
#     Device supports vendor reserved register @ 0x3a
#     Device supports vendor reserved register @ 0x3d
#
# Edit the entries below to uncomment out the configuration required.
# Note that only the first value of any range is given, this may be
changed if required
# Don't forget to uncomment the activate (ACT Y) when happy

(CONFIGURE INT1031/3383107382 (LD 0
#     Compatible device id INT1030
#     Logical device decodes 10 bit IO address lines
#         Minimum IO base address 0x0200
#         Maximum IO base address 0x0390
#         IO base alignment 16 bytes
#         Number of IO addresses required: 16
(IO 0 (SIZE 16) (BASE 0x0210) (CHECK))
#     IRQ 3, 4, 5, 7, 9, 10, 11 or 12.
#         High true, edge sensitive interrupt (by default)
# (INT 0 (IRQ 3 (MODE +E)))
(NAME "INT1031/3383107382[0]{Intel PRO/10+ or compatible adapter}")
(ACT Y)
))
# End tag... Checksum 0x00 (OK)

# Returns all cards to the "Wait for Key" state
(WAITFORKEY)
***************************************************************
Comment 5 Bill Nottingham 1999-10-20 17:11:59 EDT
That's odd - you really should configure the IRQ to
*something*; while 3 might be (probably is) in use
by a serial port, something else is probably available.

You might have to enable an IRQ in the BIOS as 'reserved
for legacy use'.
Comment 6 margarita 1999-10-20 18:51:59 EDT
I configured the IRQ to 5 and the address to 0x210 in the linuxconf
configuration. This is the data that windows reported and with no
conflicts.  I can't configure the IRQ in the isapnp.conf using
this motherboard (1st motherboard), although I could with the old
IWILL  I had (burned up). This address is usually reserved for the
sound card. I have some software that will tell me what IRQ's are
available when I put in the sound card, but that's another problem.
Comment 7 margarita 1999-10-20 23:33:59 EDT
A final note (unless you people have more to say):
ifconfig lockes up the system completely if isapnp.conf does not
do the job properly. There should be a timeout on ifconfig to let
go of it's death grip on the system. About 50% of the time the root
filesystem will be trashed beyound fsck's help. That (the timeout
for ifconfig) should be fixed.

Note You need to log in before you can comment on or make changes to this bug.