Bug 548231 - KMS:RV770:HD4850 Screen corrupted on resume (not a lockup)
Summary: KMS:RV770:HD4850 Screen corrupted on resume (not a lockup)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-17 01:16 UTC by Chris Adams
Modified: 2010-12-04 01:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-04 01:33:49 UTC


Attachments (Terms of Use)
dmesg after restore (52.82 KB, text/plain)
2009-12-19 15:54 UTC, Chris Adams
no flags Details
Xorg.0.log after restore (94.26 KB, text/plain)
2009-12-19 15:54 UTC, Chris Adams
no flags Details

Description Chris Adams 2009-12-17 01:16:19 UTC
When I suspend/resume my desktop with a Radeon 4850 card, the video is corrupted when I resume.  It is stretched to the right and looks "ghosty" (kind of like bad analog TV signal reception).  If I switch to a console, it looks the same.  I tried:

- nomodeset: only difference was that trying to switch to a text console after resume was completely corrupted

- had mesa-dri-drivers-experimental; removed that

- had BIOS "run VGA BIOS after S3" option disabled; tried enabling it and the system froze during resume

This is an up-to-date F12 system.  The video comes out the HDMI port to a DVI port on an LCD panel.

Suspend/resume worked on F11 (had other intermittent problems with disk, but video worked 100%).

Comment 1 Chris Campbell 2009-12-19 15:41:03 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Chris Adams 2009-12-19 15:54:30 UTC
Created attachment 379354 [details]
dmesg after restore

Comment 3 Chris Adams 2009-12-19 15:54:55 UTC
Created attachment 379355 [details]
Xorg.0.log after restore

Comment 4 Chris Campbell 2009-12-21 19:27:40 UTC
Thank you for your logs. Setting keyword triaged, status to assigned (Fedora 12) per new triage policy. Assigned to airlied, and cc:d to ajax. Please reassign or cc as necessary.

This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Jérôme Glisse 2010-01-11 13:14:11 UTC
What is the full reference of your screen ?

Comment 6 Chris Adams 2010-01-11 13:55:40 UTC
I'm afraid I don't know what you are asking.  What do you mean by "full reference of your screen"?

Comment 7 Jérôme Glisse 2010-01-11 15:33:22 UTC
For instance: Dell P2310H, or Samsung SyncMaster 172x 
Ie manufacturer and model of your screen.

Comment 8 Chris Adams 2010-01-11 15:48:04 UTC
Ah, I see.  I have a Samsung 2493HM LCD.  Because it is the cable I had on hand (and because the monitor's EDID data is bogus on the HDMI port), it is connected via a HDMI cable with a DVI-HDMI adapter on the monitor end (DVI on the monitor to HDMI on the video card).  The card is a Gigabyte GV-R485MC-1GI.

As a FYI: I did try the latest xorg-x11-*, libdrm*, mesa*, and plymouth* from updates-testing last week; still the same result.

Comment 9 Bug Zapper 2010-11-04 03:09:28 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Bug Zapper 2010-12-04 01:33:49 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.