Bug 548311 - [abrt] crash detected in mc-1:4.7.0-0.5.pre4.fc12
Summary: [abrt] crash detected in mc-1:4.7.0-0.5.pre4.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ab2011148569efe5206884fad2c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-17 05:03 UTC by nicu
Modified: 2013-07-02 23:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-10 12:59:56 UTC


Attachments (Terms of Use)
File: backtrace (1.94 KB, text/plain)
2009-12-17 05:03 UTC, nicu
no flags Details
strace mc output (336 bytes, text/plain)
2009-12-18 15:25 UTC, nicu
no flags Details

Description nicu 2009-12-17 05:03:01 UTC
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. open a console
2. type: mc
3. done

backtrace
-----
Debuginfo absent: 4e6516b5bbce2eb41c9ef4fc8aa2c4f1db8f3cfd
Debuginfo absent: 690ac3e8388f1342bb8ea45e0afa491882f61f0f
Debuginfo absent: 783d7454b6cae307658216edfa8510e290474453
Debuginfo absent: f94fccb8ce475e65801a4722f113f1fd3311d8bf
Core was generated by `/usr/bin/mc -P /tmp/mc-nicu/mc.pwd.5059'.
Program terminated with signal 11, Segmentation fault.
#0  0x080554ec in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
	in ../sysdeps/unix/sysv/linux/i386/geteuid.c

Thread 1 (Thread 5119):
#0  0x080554ec in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#1  0x0805558a in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#2  0x0808b2c4 in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#3  0x0808cfc1 in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#4  0x0808d12b in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#5  0x0808f112 in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#6  0x0808f8cf in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.
#7  0x0052cbb6 in __libc_start_main (main=<value optimized out>, 
    argc=<value optimized out>, ubp_av=<value optimized out>, 
    init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=<value optimized out>)
    at libc-start.c:220
        result = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {6844404, 0, 0, 
    -1077409640, 961545147, 215397572}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x3, 0x804f050}, data = {prev = 0x0, cleanup = 0x0, 
              canceltype = 3}}}
        not_first_call = <value optimized out>
#8  0x0804f071 in geteuid () at ../sysdeps/unix/sysv/linux/i386/geteuid.c:36
No symbol table info available.

cmdline: /usr/bin/mc -P /tmp/mc-nicu/mc.pwd.5059
component: mc
executable: /usr/bin/mc
kernel: 2.6.31.6-166.fc12.i686
package: mc-1:4.7.0-0.5.pre4.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 nicu 2009-12-17 05:03:04 UTC
Created attachment 378893 [details]
File: backtrace

Comment 2 Jindrich Novy 2009-12-17 07:37:43 UTC
The backtrace is useless unfortunately. Could you please try to install mc-debuginfo manually and try again? Do you use some special user setup for the machine (thousands of user accounts, etc.)? Does it happen when you run mc as root? Thanks.

Comment 3 nicu 2009-12-17 16:22:10 UTC
(In reply to comment #2)
> The backtrace is useless unfortunately. Could you please try to install
> mc-debuginfo manually and try again? Do you use some special user setup for the
> machine (thousands of user accounts, etc.)? Does it happen when you run mc as
> root? Thanks.  

I will install mc-debuginfo, in the meantime: it's a regular laptop (dell 1520, 2 users) and yes, it happens when I run mc as root also. (cursor retains that blue background of mc when segfault). it worked fine until the last bach of updates.

Comment 4 nicu 2009-12-17 16:38:39 UTC
ok, installed mc-debuginfo... now how to get more info?

Comment 5 Denys Vlasenko 2009-12-17 17:40:35 UTC
If you install newer abrt (newest is at: http://koji.fedoraproject.org/koji/buildinfo?buildID=147061), then start abrt-gui, find the crash in the list, press [Report] on the toolbar - the report dialog will appear - then press [Refresh] in that dialog.

Then you can simply cut-n-paste updated backtrace from the report dialog.

Comment 6 Jindrich Novy 2009-12-17 19:54:32 UTC
Alternatively, you can:

1. run "gdb mc" in a terminal
2. write run
<mc crashes>
3. write bt and cut-and-paste the backtrace.

Comment 7 nicu 2009-12-18 10:19:25 UTC
(In reply to comment #6)
> Alternatively, you can:
> 
> 1. run "gdb mc" in a terminal
> 2. write run
> <mc crashes>
> 3. write bt and cut-and-paste the backtrace.  

I've done this one, this is the result:

Program received signal SIGSEGV, Segmentation fault.
0x080554ec in geteuid ()
(gdb) bt
#0  0x080554ec in geteuid ()
#1  0x0805558a in geteuid ()
#2  0x0808b2c4 in geteuid ()
#3  0x0808cfc1 in geteuid ()
#4  0x0808d12b in geteuid ()
#5  0x0808f112 in geteuid ()
#6  0x0808f8cf in geteuid ()
#7  0x0065dbb6 in __libc_start_main () from /lib/libc.so.6
#8  0x0804f071 in geteuid ()
(gdb)

Comment 8 Jindrich Novy 2009-12-18 10:50:31 UTC
Hmm, this one looks strange as the crash is somewhere within the recursive geteuid() call... geteuid(2) accepts no arguments and always succeeds what makes me doubt that anything is wrong with mc itself but glibc. Reassigning to get more info about it.

For now, because the backtrace stack is too long, could you just attach here an output of "strace mc" ? We may find out more from it. Thanks.

Comment 9 Jakub Jelinek 2009-12-18 12:26:09 UTC
geteuid is defined in libc.so.6, while the above 0x080XXXXX addresses are clearly in the executable.  No idea why is gdb confused, but those addresses certainly aren't geteuid.

Comment 10 Jindrich Novy 2009-12-18 12:50:25 UTC
Jan, any idea what's gone wrong with gdb here?

Comment 11 Jan Kratochvil 2009-12-18 14:15:39 UTC
Guessing GDB did not read the debuginfo at all, for some reason.
"geteuid@plt" is the last synthetic symbol of ".plt" section - ".text" section follows it.

There may be some GDB bug that it assumes continuation of the last size-less symbol despite it comes from a different section.  But still this point is unrelated to this Bug and would not help it much.

nicu, some "rpm -q mc mc-debuginfo" and "rpm -V mc mc-debuginfo" may explain more.  Also some copy-paste of the full GDB output (where it may complain some way on the debuginfo).

Comment 12 nicu 2009-12-18 15:25:21 UTC
Created attachment 379232 [details]
strace mc output

strace mc output

Comment 13 nicu 2009-12-18 15:28:28 UTC
(In reply to comment #11)
> Guessing GDB did not read the debuginfo at all, for some reason.
> "geteuid@plt" is the last synthetic symbol of ".plt" section - ".text" section
> follows it.
> 
> There may be some GDB bug that it assumes continuation of the last size-less
> symbol despite it comes from a different section.  But still this point is
> unrelated to this Bug and would not help it much.
> 
> nicu, some "rpm -q mc mc-debuginfo" and "rpm -V mc mc-debuginfo" may explain
> more.  Also some copy-paste of the full GDB output (where it may complain some
> way on the debuginfo).  

rpm -q mc mc-debuginfo :
mc-4.7.0-0.5.pre4.fc12.i686
mc-debuginfo-4.7.0-0.4.pre2.fc12.i686
--------------------------------------------------------
rpm -V mc mc-debuginfo :
..?......    /usr/libexec/mc/cons.saver
--------------------------------------------------------
gdb mc :
GNU gdb (GDB) Fedora (7.0-9.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/mc...
warning: the debug information found in "/usr/lib/debug//usr/bin/mc.debug" does not match "/usr/bin/mc" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug/usr/bin/mc.debug" does not match "/usr/bin/mc" (CRC mismatch).

(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install mc-4.7.0-0.5.pre4.fc12.i686

----------------------------------
Yep, it seems that i must install something... but need some instructions on what :)

Comment 14 Jan Kratochvil 2009-12-18 15:38:11 UTC
rpm -e mc-debuginfo
rpm -i http://kojipkgs.fedoraproject.org/packages/mc/4.7.0/0.5.pre4.fc12/i686/mc-debuginfo-4.7.0-0.5.pre4.fc12.i686.rpm

This is still YUM Bug 432806 (which is fixed insufficiently).

Comment 15 Jindrich Novy 2009-12-21 14:37:49 UTC
Could you please try this mc? :

http://koji.fedoraproject.org/koji/taskinfo?taskID=1883757

I will release an update in case it fixes this one as well.

Comment 16 nicu 2009-12-22 05:59:41 UTC
(In reply to comment #15)
> Could you please try this mc? :
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1883757
> 
> I will release an update in case it fixes this one as well.  

I have installed and works fine so far, thank you.

Comment 17 Fedora Update System 2009-12-22 16:26:13 UTC
mc-4.7.0-0.6.pre4.20091221git.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/mc-4.7.0-0.6.pre4.20091221git.fc12


Note You need to log in before you can comment on or make changes to this bug.