This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 548390 - Bad default font in Emacs
Bad default font in Emacs
Status: CLOSED DUPLICATE of bug 546490
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-17 05:08 EST by Mattias Ellert
Modified: 2009-12-18 03:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 03:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of an emacs window (63.65 KB, image/png)
2009-12-17 05:08 EST, Mattias Ellert
no flags Details

  None (edit)
Description Mattias Ellert 2009-12-17 05:08:01 EST
Created attachment 378955 [details]
Screenshot of an emacs window

Description of problem:
Emacs has suddenly started using a very strange font as the default font. See the attached screenshot.

Version-Release number of selected component (if applicable):
emacs-23.1-13.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start emacs
2. See the wrong font being used.
  
Actual results:
A weird font is used.

Expected results:
A suitable font should be used. Like the one used before this bug appeared.

Additional info:
I have tried removing and reinstalling emacs, but that doesn't help.
I have tried deleting my ~/.emacs file, but that doesn't help either.
I have tried removing and recreating the fontconfig cache files in /var/cache/fontconfig, also doesn't help.
Comment 1 Karel Klíč 2009-12-17 07:08:56 EST
Mattias, the situation you described cannot be reproduced without knowing what triggered the change of the font. Was it caused by an update? Did you install a new package, added fonts manually, or changed some configuration?
Comment 2 Mattias Ellert 2009-12-17 07:49:16 EST
(In reply to comment #1)
> Mattias, the situation you described cannot be reproduced without knowing what
> triggered the change of the font. Was it caused by an update? Did you install a
> new package, added fonts manually, or changed some configuration?  

I have not changed any defaults in the emacs configuration except for checking the "Do not show this start-up screen" check-box to get rid of the extremely annoying start-up screen.

I have not installed any fonts on the computer that is not packaged by Fedora.

I did install the emacs-23.1-13 update on 2009-12-07, and the freetype-2.3.11-3 and fontconfig-2.8.0-1 updates 2009-12-11. The problems started around that time.
Comment 3 Mattias Ellert 2009-12-17 14:13:36 EST
I made a little investigation:

Running "yum downgrade fontconfig fontconfig-devel" so that I get the previous fontconfig-2.7.3-1 version restores the correct default font in emacs.

If I run "yum update" again after this and get the current fontconfig-2.8.0-1 again the problem with the wrong default font in emacs comes back again.

So the problem is triggered by the fontconfig update.
Comment 4 Karel Klíč 2009-12-18 03:05:34 EST
Thank you for the investigation.

It seems fontconfig people are already looking into the problem, so I am closing this as a duplicate of their bug.

*** This bug has been marked as a duplicate of bug 546490 ***

Note You need to log in before you can comment on or make changes to this bug.