Bug 54842 - gcc 2.96 20000731 crashed while compiling kernel, uaccess.h
Summary: gcc 2.96 20000731 crashed while compiling kernel, uaccess.h
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-20 19:04 UTC by Yegor Bryukhov
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-20 19:06:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yegor Bryukhov 2001-10-20 19:04:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
make bzImage

...

gcc -D__KERNEL__ -I/usr/src/linux-2.4.9-6/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common
-Wno-unused -pipe -mpreferred-stack-boundary=2 -march=i686    -c -o
nodemgmt.o nodemgmt.c
In file included from /usr/src/linux-2.4.9-6/include/linux/compatmac.h:137,
                 from /usr/src/linux-2.4.9-6/include/linux/mtd/compatmac.h:20,
                 from /usr/src/linux-2.4.9-6/include/linux/mtd/mtd.h:12,
                 from nodemgmt.c:41:
/usr/src/linux-2.4.9-6/include/asm/uaccess.h: In function `verify_area':
/usr/src/linux-2.4.9-6/include/asm/uaccess.h:65: Internal error:
Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [nodemgmt.o] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.9-6/fs/jffs2'
make[1]: *** [_subdir_jffs2] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.9-6/fs'
make: *** [_dir_fs] Error 2
[root@swing linux-2.4.9-6]#

second run of "make bzImage" goes through this point
without an eror.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Jakub Jelinek 2001-10-22 10:17:34 UTC
If gcc ICE cannot be reproduced on the same file with the same options,
it in 99.9% cases is actually a hardware bug.


Note You need to log in before you can comment on or make changes to this bug.