Bug 54843 - kernel sources: irlan_client.c has a typo
Summary: kernel sources: irlan_client.c has a typo
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-20 19:19 UTC by Yegor Bryukhov
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:48:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yegor Bryukhov 2001-10-20 19:19:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917

Description of problem:
gcc -D__KERNEL__ -I/usr/src/linux-2.4.9-6/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common
-Wno-unused -pipe -mpreferred-stack-boundary=2 -march=i686    -c -o
irlan_client.o irlan_client.c
irlan_client.c: In function `irlan_client_open_ctrl_tsap':
irlan_client.c:242: `notify_t0notify' undeclared (first use in this function)
irlan_client.c:242: (Each undeclared identifier is reported only once
irlan_client.c:242: for each function it appears in.)
irlan_client.c:253: `notify' undeclared (first use in this function)
make[4]: *** [irlan_client.o] Error 1
make[4]: Leaving directory `/usr/src/linux-2.4.9-6/net/irda/irlan'
make[3]: *** [first_rule] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.9-6/net/irda/irlan'
make[2]: *** [_subdir_irlan] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.9-6/net/irda'
make[1]: *** [_subdir_irda] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.9-6/net'
make: *** [_dir_net] Error 2
[root@swing linux-2.4.9-6]#

It looks like line 242 should be "notify_t notify"
instead of "notify_t0notify"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just include this source into kernel compilation
2.
3.
	

Additional info:

Comment 1 Alan Cox 2003-06-07 18:48:21 UTC
Seems to be a local corruption



Note You need to log in before you can comment on or make changes to this bug.