Bug 54846 - "inappropriate ioctl for device" upon login
"inappropriate ioctl for device" upon login
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-20 18:11 EDT by jam
Modified: 2016-11-24 09:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-22 10:43:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jam 2001-10-20 18:11:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
[~] [6:04pm] [aristotle] % router
Last login: Sat Oct 20 18:04:44 from aristotle.int
You have mail.
---> Warning: no access to tty (Inappropriate ioctl for device).
---> Thus no job control in this shell.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rsh <machine>
or
2. telnet <machine>


	

Actual Results:  [~] [6:04pm] [aristotle] % router
Last login: Sat Oct 20 18:04:44 from aristotle.int
You have mail.
Warning: no access to tty (Inappropriate ioctl for device).
Thus no job control in this shell.



Expected Results:  did not expect warning.



Additional info:

- recently used up2date to bring machine to latest versions of packages
installed.

- shells opened no longer accept arrow keys or other ctrl characters
(readline not functioning?)

- does not appear to be a pam problem, since 'telnet' and 'rsh' give the
same results (maybe tcsh problem?)
Comment 1 jam 2001-10-20 20:11:31 EDT
this problem started after I updated my system (with up2date) to the latest 7.1
RPMs.
Comment 2 Bill Nottingham 2001-10-22 10:40:37 EDT

*** This bug has been marked as a duplicate of 54741 ***
Comment 3 jam 2001-10-22 10:43:41 EDT
discovered that when I ssh into the remote machine, everything is fine. arrow
keys work, ^L works, etc.

note that both the machines in this test have been upgraded to most recent 7.1
patches (except the kernel)

Note You need to log in before you can comment on or make changes to this bug.