Bug 548500 - [abrt] crash detected in yum-utils-1.1.24-2.fc13
[abrt] crash detected in yum-utils-1.1.24-2.fc13
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-12-17 11:25 EST by Baris Cicek
Modified: 2014-01-21 18:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.1.25-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-01-12 14:45:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: backtrace (1.96 KB, text/plain)
2009-12-17 11:25 EST, Baris Cicek
no flags Details
Fedora.repo file (1.14 KB, application/octet-stream)
2009-12-17 12:27 EST, Baris Cicek
no flags Details

  None (edit)
Description Baris Cicek 2009-12-17 11:25:29 EST
abrt 1.0.0 detected a crash.

Summary: TB69b28093 yumRepo.py:1444:_getRepoXML:RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

Traceback (most recent call last):
  File "/usr/bin/repo-graph", line 118, in <module>
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 84, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 99, in _getTs
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 110, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 724, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 553, in _getSacks
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 277, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 223, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1258, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1448, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1444, in _getRepoXML
    raise Errors.RepoError, msg
RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

Local variables in innermost frame:
msg: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again
self: fedora
e: Cannot retrieve metalink for repository: fedora. Please verify its path and try again

cmdline: /usr/bin/python /usr/bin/repo-graph 
component: yum-utils
executable: /usr/bin/repo-graph
kernel: 2.6.32-7.fc13.x86_64
package: yum-utils-1.1.24-2.fc13
uuid: 69b28093
Comment 1 Baris Cicek 2009-12-17 11:25:32 EST
Created attachment 379037 [details]
File: backtrace
Comment 2 seth vidal 2009-12-17 12:10:45 EST
Can you post your /etc/yum.repos.d/fedora.repo file. Thanks
Comment 3 Baris Cicek 2009-12-17 12:27:19 EST
Created attachment 379059 [details]
Fedora.repo file
Comment 4 seth vidal 2009-12-17 12:33:46 EST
if you run:

yum repolist -v

does that work?
Comment 5 Baris Cicek 2009-12-17 12:40:21 EST
No. Here's the output.

[draco@alanine ~]$ yum repolist -v
Not loading "blacklist" plugin, as it is disabled
Loading "dellsysidplugin2" plugin
Loading "fastestmirror" plugin
Loading "presto" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Config time: 0.204
rpmdb time: 0.076
Yum Version: 3.2.25
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=x86_64&country=EU error was
14: PYCURL ERROR 7 - ""
http://download.fedoraproject.org/pub/fedora/linux/development/x86_64/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - ""
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rawhide. Please verify its path and try again
Comment 6 seth vidal 2009-12-17 12:47:06 EST
I think you're seeing:

Comment 7 seth vidal 2010-01-12 14:45:16 EST

*** This bug has been marked as a duplicate of bug 548269 ***
Comment 8 seth vidal 2010-01-12 14:48:14 EST
I've also applied a patch upstream so this won't traceback in the future.
Comment 9 Kamil Dudka 2010-01-12 17:39:06 EST
Wait, this can't be duplicate of 548269.  The bug report is about a *crash* detected in yum-utils.  Bug 548269 is *not* about any crash.  Situation that any mirror is not available may happen independently on curl.  I don't think it is enough reason to crash.  The crash itself simply can't be fixed in curl.
Comment 10 seth vidal 2010-01-13 09:38:21 EST
You'll note the crash is 'cannot find metalink'. Here's how the crash would occur:

repo-graph attempts to grab info from the repos.
it cannot reach the repo b/c of the issue in 548269
it raises a repoerror
this crashed repo-graph b/c it is not expecting the exception.

1. this is started by the issue in 548269
2. I applied an exception catch in repo-graph to handle these problems in the future.
Comment 11 Kamil Dudka 2010-01-13 10:04:56 EST
Does "exception catch" mean yum-util won't crash next time it happens?

If so, the bug itself (crash) has been resolved within yum-utils.  Closing it as duplicate can cause only confusion.  As duplicates are usually marked bugs with the same behavior and the same resolution.
Comment 12 seth vidal 2010-01-13 10:09:26 EST
It means the exception has been caught. The CAUSE of the exception is why I closed it as a duplicate.

Why is this such a big deal?
Comment 13 Kamil Dudka 2010-01-13 10:13:57 EST
It would be also good to attach and/or reference the patch you applied upstream and mention the version in which the flaw was fixed.

> Why is this such a big deal?    

Because duplicated bugs are handled differently when searching on BZ.  People may need to know this bug has been already reported and fixed.
Comment 14 seth vidal 2010-01-13 10:19:36 EST

Have you looked at what repograph does? Have you looked at how seldom it is used by anyone? I almost removed it from yum-utils b/c it is completely frelling silly.

Here's the exciting patch:


closed upstream - hope you're completely happy.
Comment 15 Kamil Dudka 2010-01-13 10:31:01 EST
(In reply to comment #14)

It may sounds stupid but I have really no idea what repograph is :-)

You seems to be more educated about repograph, so you can summarize it briefly.  Other people encountering the bug may be also interested.  The title is "[abrt] crash detected in yum-utils...", so I started from there.  If it is misleading, you may tweak the title as well.

Thanks for the link!
Comment 16 Fedora Update System 2010-01-27 07:13:31 EST
yum-utils-1.1.25-1.fc12 has been submitted as an update for Fedora 12.
Comment 17 Fedora Update System 2010-02-11 09:48:00 EST
yum-utils-1.1.25-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.