Bug 548501 - RHQ, default configuration, GUI Console URL: please change from loopback to resource's IP or hostname
RHQ, default configuration, GUI Console URL: please change from loopback to r...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://10.16.120.153:7080/admin/confi...
: SubBug
Depends On:
Blocks: rhq_spearhead
  Show dependency treegraph
 
Reported: 2009-12-17 11:30 EST by wes hayutin
Modified: 2014-05-16 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 16:16:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-12-17 11:30:38 EST
Description of problem:

It would probably less confusing to users to change the default entry here from 127.0.0.1 (loopback) to the resources real hostname or ip.  The ip that is sent in alerts will be changed from

es> Alert -- test01 (on 10-16-120-153.guest.rhq.lab.eng.bos.redhat.com RHQ Agent):  http://localhost:7080/alerts/Alerts.do?mode=viewAlert&id=10002&a=10011

to:

Alert -- test01 (on 10-16-120-153.guest.rhq.lab.eng.bos.redhat.com RHQ Agent):  http://10.16.120.153:7080/alerts/Alerts.do?mode=viewAlert&id=10002&a=10071


Administration -> Server Configuration -> Settings
RHQ General Configuration Properties 
GUI Console URL:  	

Thank you!
Comment 1 John Mazzitelli 2009-12-17 12:53:28 EST
content = content.replaceAll("@@@BASEURL@@@", "http://" + ServerProperties.getValidServerBindAddress(props) + ":" + ServerProperties.getHttpPort(props) + "/");

That is code inside the installer war - the installer will set the default value in the  DB using that code above - i.e. the server bind address.

Perhaps we should use a different default here?

Note that this will only take effect when you do a "Overwrite Schema" - because that  @@@BASEURL@@@ is a replacement string inside the sysconfig-data.xml file that is used to prepopulate the database when the schema is first created. Adding more servers to the cloud or re-installing the server with the "Keep Existing Data" option won't change this value.

This base url is the value you see in the UI in Administration>SystemConfiguration>Settings.
Comment 2 wes hayutin 2010-02-16 11:58:54 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 12:03:39 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.