Bug 548594 - turbogears-sqlcreate.patch breaks basic `tg-admin sql create` usage
Summary: turbogears-sqlcreate.patch breaks basic `tg-admin sql create` usage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: TurboGears
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 550604 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-17 21:25 UTC by Luke Macken
Modified: 2016-09-20 02:40 UTC (History)
5 users (show)

Fixed In Version: 1.0.9-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-28 20:05:59 UTC


Attachments (Terms of Use)

Description Luke Macken 2009-12-17 21:25:54 UTC
Description of problem:

The recent turbogears-sqlcreate.patch that is applied to our TurboGears breaks basic `tg-admin sql create` usage:

lmacken@x300 ~/code/git.fedorahosted.org/bodhi $ tg-admin --config=bodhi.cfg sql create
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/lib/cptools.py:3: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/filters/sessionfilter.py:33: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/lib/python2.6/site-packages/sqlobject/converters.py:165: DeprecationWarning: the sets module is deprecated
  from sets import Set, ImmutableSet
/usr/lib64/python2.6/site-packages/dispatch/predicates.py:379: DeprecationWarning: object.__new__() takes no parameters
  return ExprBase.__new__(klass,function,*argexprs)
Using database URI sqlite:///var/tmp/bodhi.sqlite
Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 8, in <module>
    load_entry_point('TurboGears==1.0.9', 'console_scripts', 'tg-admin')()
  File "/usr/lib/python2.6/site-packages/turbogears/command/base.py", line 403, in main
    command.run()
  File "/usr/lib/python2.6/site-packages/turbogears/command/base.py", line 133, in run
    pkgversion = eggname.split('-')[-2]
IndexError: list index out of range

Comment 1 Fedora Update System 2009-12-17 23:38:49 UTC
TurboGears-1.0.9-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/TurboGears-1.0.9-2.fc11

Comment 2 Fedora Update System 2009-12-17 23:39:14 UTC
TurboGears-1.0.9-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/TurboGears-1.0.9-2.fc12

Comment 3 Fedora Update System 2009-12-17 23:39:38 UTC
TurboGears-1.0.9-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/TurboGears-1.0.9-2.el5

Comment 4 Fedora Update System 2009-12-18 19:57:12 UTC
TurboGears-1.0.9-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update TurboGears'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-1027

Comment 5 Fedora Update System 2009-12-22 04:39:09 UTC
TurboGears-1.0.9-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update TurboGears'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13405

Comment 6 Fedora Update System 2009-12-22 04:41:05 UTC
TurboGears-1.0.9-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update TurboGears'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13427

Comment 7 Toshio Ernie Kuratomi 2009-12-27 18:52:27 UTC
*** Bug 550604 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2009-12-28 20:05:55 UTC
TurboGears-1.0.9-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-12-28 20:06:40 UTC
TurboGears-1.0.9-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-01-05 22:31:16 UTC
TurboGears-1.0.9-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.