Bug 54861 - pot file header generated by pygettext is incorrect
pot file header generated by pygettext is incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: python2 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-21 17:45 EDT by Christian Rose
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 09:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2001-10-21 17:45:22 EDT
The pygettext.py script generates incorrect pot file headers.

First of all, it does not add a POT-Creation-Date (which is very much
needed to determine how "fresh" a pot file is).

Second, the PO-Revision-Date is of the wrong format (it should be as in the
output of `date +"%Y-%m-%d %H:%M%z"').
Comment 1 Trond Eivind Glomsrxd 2001-10-26 12:06:32 EDT
The pygettext in python 2.2 is slightly different - I'll need to check if the
problem is still around.
Comment 2 Christian Rose 2002-06-08 19:08:55 EDT
This faulty pot file header problem seems to still be around (see the current
pot file for redhat-logviewer).
Comment 3 Mihai Ibanescu 2002-10-22 12:22:45 EDT
Patching pygettext is not exactly difficult, it would be nice if the upstream
python maintainers would accept the patch as well.
Comment 4 Mihai Ibanescu 2004-08-31 09:49:50 EDT
Seems to be fixed in python 2.3.4"

"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\\n"

Note You need to log in before you can comment on or make changes to this bug.