Bug 54863 - glibc-2.2.4-19 crashes rpm in RedHat 7.1
glibc-2.2.4-19 crashes rpm in RedHat 7.1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-21 18:57 EDT by Bob Rintel
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 02:43:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Rintel 2001-10-21 18:57:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.9-6 i686)

Description of problem:
The exact set of installed packages seems to matter, since this only
happens on one of
my machines, but it happens at exactly the same point every time.  I
install RedHat 7.1
from CD-ROM without Gnome, then cd to a directory containing glibc-2.2.4-19
errata, then type "rpm -Fvh *" and it says "Segmentation fault (core
dumped)"

This also happens if you install just the glibc* packages, or if you
install everything but them and then install them. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install RedHat 7.1 from CD-ROM without Gnome
2. rpm -Fvh * [in a directory containing the glibc-2.2.4-19 errata]
3.
	

Actual Results:  It says Preparing, gets to 33%, and says "Segmentation
fault (core dumped)"


Expected Results:  It should install

Additional info:

This is the output of "rpm -qa":

indexhtml-7.1-2
setup-2.4.7-1
statserial-1.1-20
kudzu-devel-0.98.10-1
pump-devel-0.8.11-1
cdparanoia-alpha9.7-7
cracklib-2.7-8
dip-3.3.7o-22
file-3.33-1
glib-1.2.9-1
iputils-20001110-1
libtermcap-2.0.8-26
mailx-8.1.1-20
bash-2.04-21
hotplug-2001_02_14-15
MAKEDEV-3.1.0-14
ncurses-5.2-8
diffutils-2.7-21
findutils-4.1.6-2
ash-0.3.7-1
m4-1.4.1-4
nkf-1.92-4
ORBit-0.5.7-3
pnm2ppa-1.04-1
procps-2.0.7-8
psutils-1.17-10
readline-4.1-9
rsh-0.17-2.5
console-tools-19990829-34
dev-3.1.0-14
newt-0.50.22-2
slocate-2.5-5
syslinux-1.52-1
tcp_wrappers-7.6-18
lilo-21.4.4-13
time-1.7-13
utempter-0.5.2-4
wget-1.6-2
cracklib-dicts-2.7-8
gpm-1.19.3-16
ppp-2.4.0-2
autofs-3.1.7-14
wvdial-1.41-12
libungif-4.1.0-7
SDL-1.1.7-3
expect-5.31-53
tksysv-1.3-2
libmng-1.0.0-2
libxml-1.8.10-1
mozilla-psm-0.7-15
gdk-pixbuf-0.8.0-7
locale_config-0.2-4
python-1.5.2-30
pygnome-1.0.53-7
rpm-4.0.2-8
timidity++-2.10.3-0.a2.3
mutt-1.2.5i-9
kernel-pcmcia-cs-3.1.24-2
ipchains-1.3.10-7
portmap-4.0-35
rp-pppoe-2.6-5
rhn_register-gnome-1.3.1-1
xcdroast-0.98a8-2
netscape-communicator-4.76-11
mkxauth-1.7-15
XFree86-100dpi-fonts-4.0.3-5
xinitrc-3.6-1
plugger-3.2-9
xsri-1.0-8
gv-3.5.8-11
yp-tools-2.4-7
mtools-3.9.7-4
xmorph-2000.04.28-9
Maelstrom-3.0.1-11
xboing-2.4-12
xpilot-4.3.0-2
sysstat-3.3.5-3
apacheconf-0.7-2
mod_perl-1.24_01-2
dialog-0.9a-4
docbook-dtd40-sgml-1.0-11
perl-SGMLSpm-1.03ii-4
tetex-1.0.7-15
tetex-latex-1.0.7-15
tetex-xdvi-1.0.7-15
im-140-3
bison-1.28-5
cproto-4.6-7
db1-devel-1.85-5
dev86-0.15.0-5
flex-2.5.4a-13
gdbm-devel-1.8.0-5
libtool-1.3.5-8
Mesa-devel-3.4-13
njamd-0.8.0-3
pmake-1.45-1
rpm-build-4.0.2-8
strace-4.2.20010119-3
XFree86-devel-4.0.3-5
bc-1.06-2
iproute-2.2.4-10
shapecfg-2.2.12-5
psgml-1.2.1-13
fvwm2-2.2.4-9
e2fsprogs-1.23-1.7.1
gcc-g77-2.96-85
libstdc++-2.96-85
losetup-2.11b-3
mount-2.11b-3
openssl-0.9.6-9
openldap-devel-2.0.11-8
samba-common-2.0.10-2
sendmail-cf-8.11.6-1.7.1
util-linux-2.11f-11.7.1
kernel-2.4.9-6
openssh-askpass-2.9p2-8.7
quota-3.01pre9-0.7.1
xloadimage-4.1-20
ghostscript-fonts-5.50-3
gnome-audio-1.0.0-12
mailcap-2.1.4-2
redhat-release-7.1-1
glibc-2.2.2-10
termcap-11.0.1-8
gsm-devel-1.0.10-2
man-pages-1.35-5
pciutils-devel-2.1.8-19
awesfx-0.4.3a-7
cdda2wav-1.9-6
cdrecord-1.9-6
compat-libstdc++-6.2-2.9.0.14
db1-1.85-5
db3-3.1.17-7
dosfstools-2.2-8
eject-2.0.2-7
finger-0.17-7
gdbm-1.8.0-5
gmp-3.1.1-3
inews-2.3.1-2
ksymoops-2.4.0-3
libogg-1.0beta4-2
libtool-libs-1.3.5-8
lrzsz-0.12.20-7
mingetty-0.9.4-16
mktemp-1.5-8
audiofile-0.1.11-1
esound-0.2.22-1
groff-1.16.1-7
mpg123-0.59r-10
cdp-0.33-20
cpio-2.4.2-20
ed-0.2-19
at-3.1.8-16
gawk-3.0.6-1
grep-2.4.2-5
dhcpcd-1.3.18pl8-10
less-358-16
make-3.79.1-5
mikmod-3.1.6-10
ncftp-3.0.2-1
netpbm-9.9-5
nmh-1.0.4-8
bind-utils-9.1.0-10
perl-5.6.0-12
playmidi-2.4-12
popt-1.6.2-8
psmisc-19-4
aspell-0.32.6-2
pwdb-0.61.1-1
rdate-1.0-7
ftp-0.17-7
rootfiles-7.0-4
rusers-0.17-10
sed-3.02-9
shadow-utils-20000826-4
slang-1.4.2-2
kbdconfig-1.9.12-1
setuptool-1.7-2
slrn-0.9.6.4-2
sysklogd-1.4-7
talk-0.17-9
tcl-8.3.1-53
tcsh-6.10-5
elm-2.5.3-11
textutils-2.0.11-7
mkbootdisk-1.4.2-1
switchdesk-3.9.5-1
traceroute-1.4a5-25
vim-common-6.0-0.27
vorbis-1.0beta4-3
which-2.12-1
words-2-16
pam-0.74-22
cyrus-sasl-1.5.24-17
kudzu-0.98.10-1
passwd-0.64.1-4
sh-utils-2.0-13
freetype-2.0.1-4
krbafs-1.0.5-1
pam_krb5-1.31-1
XFree86-libs-4.0.3-5
control-panel-3.18-4
multimedia-2.1-21
rxvt-2.7.5-15
smpeg-0.4.2-2
exmh-2.2-9
tclx-8.2.0-53
tix-4.1.0.6-53
Xaw3d-1.5-9
libpng-1.0.9-1
ImageMagick-5.2.7-2
lynx-2.8.4-9
mozilla-mail-0.7-15
netpbm-progs-9.9-5
gnome-libs-1.2.8-11
gimp-1.2.1-5
libglade-0.14-3
pan-0.9.5-1
pygnome-libglade-0.6.6-7
4Suite-0.10.1-1
pygtk-0.6.6-7
python-xmlrpc-1.4-1
modemtool-1.22-3
rpm-python-4.0.2-8
sane-1.0.3-10
tkinter-1.5.2-30
urlview-0.9-2
apmd-3.0final-29
iptables-1.2.1a-1
lokkit-0.43-6
pidentd-3.0.12-4
nfs-utils-0.3.1-5
sndconfig-0.64.8-1
usermode-1.42-1
up2date-gnome-2.5.2-1
anacron-2.3-16
XFree86-xfs-4.0.3-5
netscape-common-4.76-11
urw-fonts-2.0-12
Mesa-3.4-13
qt-2.3.0-3
XFree86-75dpi-fonts-4.0.3-5
XFree86-twm-4.0.3-5
XFree86-xdm-4.0.3-5
xmms-1.2.4-13
xscreensaver-3.29-3
xtt-fonts-0.19990222-9
ghostscript-5.50-17
printconf-0.2.12-1
unzip-5.41-3
dos2unix-3.1-6
unix2dos-2.2-11
xpaint-2.6.1-1
gnuchess-4.0.pl80-6
trojka-1.1-17
xboard-4.1.0-1
xgammon-0.98-19
xpat2-1.06-5
xpuzzles-5.5.2-4
rsh-server-0.17-2.5
rwall-server-0.17-9
talk-server-0.17-9
ypserv-1.3.11-13
apache-1.3.19-5
expat-1.95.1-1
mod_dav-1.0.2-4
php-4.0.4pl1-9
php-ldap-4.0.4pl1-9
bind-9.1.0-10
caching-nameserver-7.1-3
sgml-common-0.5-5
docbook-dtd31-sgml-1.0-10
docbook-dtd41-sgml-1.0-10
docbook-utils-0.6-13
tetex-fonts-1.0.7-15
tetex-afm-1.0.7-15
tetex-dvips-1.0.7-15
jadetex-3.3-1
w3c-libwww-5.2.8-6
emacs-20.7-34
emacs-X11-20.7-34
autoconf-2.13-10
binutils-2.10.91.0.2-3
byacc-1.9-18
docbook-style-dsssl-1.64-2
e2fsprogs-devel-1.23-1.7.1
gcc-2.96-85
krb5-devel-1.2.2-12
arts-2.1.2-1
mkinitrd-3.2.6-1
nscd-2.2.4-19
openldap-2.0.11-8
openldap-clients-2.0.11-8
openssl-devel-0.9.6-9
samba-client-2.0.10-2
fetchmail-5.9.0-0.7.1
telnet-0.17-18
tux-2.1.0-2
initscripts-5.84.1-1
Xconfigurator-4.9.29-1
devfsd-2.4.3-12
openssh-2.9p2-8.7
openssh-server-2.9p2-8.7
wireless-tools-21-1
telnet-server-0.17-18
ypbind-1.7-8
cdecl-2.5-17
ctags-4.0.3-1
cyrus-sasl-devel-1.5.24-17
db2-devel-2.4.14-5
db3-utils-3.1.17-7
diffstat-1.27-5
expat-devel-1.95.1-1
freetype-devel-2.0.1-4
gdb-5.0rh-5
glib-devel-1.2.9-1
gmp-devel-3.1.1-3
indent-2.2.6-1
libjpeg-devel-6b-15
libpng-devel-1.0.9-1
libtiff-devel-3.5.5-10
libungif-devel-4.1.0-7
memprof-0.4.1-3
ncompress-4.2.4-21
netpbm-devel-9.9-5
patch-2.5.4-9
python-devel-1.5.2-30
readline-devel-4.1-9
rpm-devel-4.0.2-8
newt-devel-0.50.22-2
texinfo-4.0-20
Xaw3d-devel-1.5-9
gtk+-devel-1.2.9-4
arpwatch-2.1a10-39
dump-0.4b21-3
ical-2.2-21
lsof-4.51-1
screen-3.9.8-3
stat-2.2-2
xpdf-0.92-3
stunnel-3.13-3
fvwm2-icons-2.2.4-9
SysVinit-2.78-17
gnupg-1.0.6-1
gcc-c++-2.96-85
man-1.5i2-0.7x.5
modutils-2.4.6-4
procmail-3.21-0.71
glibc-common-2.2.2-10
redhat-logos-1.1.2-3
basesystem-7.0-2
tamago-4.0.6-4
bdflush-1.5-16
chkconfig-1.2.22-1
db2-2.4.14-5
fortune-mod-1.0-13
hdparm-3.9-6
libjpeg-6b-15
mkisofs-1.9-6
bzip2-1.0.1-3
mpage-2.5.1-5
info-4.0-20
fileutils-4.0.36-4
gettext-0.10.35-31
gzip-1.3-12
net-tools-1.57-6
groff-perl-1.16.1-7
logrotate-3.5.4-1
pspell-0.11.2-2
raidtools-0.90-20
rmt-0.4b21-3
rwho-0.17-10
setserial-2.17-2
sharutils-4.2.1-7
ntsysv-1.2.22-1
sox-12.17.1-2
tar-1.13.19-4
metamail-2.7-27
crontabs-1.9-2
vim-minimal-6.0-0.27
whois-1.0.6-1
authconfig-4.1.6-1
links-0.95-2
a2ps-4.13b-13
gtk+-1.2.9-4
playmidi-X11-2.4-12
tk-8.3.1-53
timetool-2.8-1
zlib-1.1.3-22
libtiff-3.5.5-10
mozilla-0.7-15
imlib-1.9.8.1-2
gphoto-0.4.3-10
pygtk-libglade-0.6.6-7
alchemist-0.16-3
pythonlib-1.28-1
rhn_register-1.3.1-1
up2date-2.5.2-1
aumix-2.7-2
isdn4k-utils-3.1-39
netcfg-2.36-3
pciutils-2.1.8-19
pump-0.8.11-1
timeconfig-3.2-1
vixie-cron-3.0.1-62
chkfontpath-1.9.5-1
XFree86-4.0.3-5
internet-config-0.40-1
XFree86-tools-4.0.3-5
xisdnload-1.38-39
xsane-0.62-4
VFlib2-2.25.1-12
printconf-gui-0.2.12-1
zip-2.3-8
freeciv-1.11.4-5
xbill-2.0-13
xjewel-1.6-15
irda-utils-0.9.13-7
rusers-server-0.17-10
finger-server-0.17-7
gd-1.8.3-7
php-imap-4.0.4pl1-9
bindconf-1.4-1
docbook-dtd30-sgml-1.0-10
openjade-1.3-13
sgml-tools-1.0.9-9
tetex-dvilj-1.0.7-15
docbook-utils-pdf-0.6-13
emacs-nox-20.7-34
automake-1.4-8
bzip2-devel-1.0.1-3
cvs-1.11-3
db3-devel-3.1.17-7
gd-devel-1.8.3-7
glibc-devel-2.2.2-10
gpm-devel-1.19.3-16
libogg-devel-1.0beta4-2
libtermcap-devel-2.0.8-26
ltrace-0.3.10-5
ncurses-devel-5.2-8
pam-devel-0.74-22
rcs-5.7-14
slang-devel-1.4.2-2
vorbis-devel-1.0beta4-3
zlib-devel-1.1.3-22
efax-0.9-8
rsync-2.4.6-2
sudo-1.6.3p6-1
mod_ssl-2.8.1-5
cpp-2.96-85
filesystem-2.1.0-2.1
krb5-libs-1.2.2-12
libstdc++-devel-2.96-85
minicom-1.83.1-8
mouseconfig-4.22-1
nss_ldap-149-4
pine-4.33-8.71
sendmail-8.11.6-1.7.1
tmpwatch-2.8-0.7.x
LPRng-3.7.4-23
kernel-headers-2.4.9-6
openssh-clients-2.9p2-8.7
xinetd-2.3.3-1
Comment 1 Michael Schwendt 2001-10-22 16:07:27 EDT
Have you verified the integrity of the packages you have downloaded?

One method:

$ rpm --checksig --nogpg glibc-2.2.4-19.i686.rpm
glibc-2.2.4-19.i686.rpm: md5 OK

Or with "md5sum":

$ md5sum glibc-2.2.4-19.i686.rpm 
9f41fb589348e7c6ec7f3666c76d6858  glibc-2.2.4-19.i686.rpm

And then compare the MD5 checksum with those listed here:
http://www.redhat.com/support/errata/RHBA-2001-121.html
Comment 2 Bob Rintel 2001-10-23 02:43:36 EDT
[root@desktop d]# rpm --checksig --nogpg *
glibc-2.2.4-19.i686.rpm: md5 OK
glibc-common-2.2.4-19.i386.rpm: md5 OK
glibc-devel-2.2.4-19.i386.rpm: md5 OK
glibc-profile-2.2.4-19.i386.rpm: md5 OK
[root@desktop d]# rpm -Fvh *
Preparing...                Segmentation fault (core dumped)            ( 33%)

I typed the commands above immediately after installing off the RedHat 7.1
CDROM, with no other packages updated.
Comment 3 Jeff Johnson 2001-11-15 18:58:31 EST
Almost all segfaults in rpm are caused by bad data from the database
Install rpm-4.0.3, and do a rpm --rebuilddb to fix. Reopen this
bug if that does not fix the problem.

Note You need to log in before you can comment on or make changes to this bug.