Bug 54864 - Add /sfs to /etc/updatedb.conf
Add /sfs to /etc/updatedb.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: slocate (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-21 19:14 EDT by Marc MERLIN
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 13:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 2001-10-21 19:14:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
This is not a bug, but it'd be nice if you add "/sfs" to PRUNEPATH
in /etc/updatedb.conf
The reason is that if someone uses the self certifying filesystem (sfs, 
http://www.fs.net/), slocate will walk all the directories of all the
filesystems automounted in /sfs. This can be rather slow with shares
mounted over the internet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Wait for updatedb cron job to run, or by running it by hand
	

Additional info:
Comment 1 Marc MERLIN 2002-07-26 13:12:56 EDT
This bug is getting a little old, it's only 5 characters to add in updatedb.conf :)

Would you mind looking into this?
(This bites most SFS users on Red Hat, Debian users are fine, and it wastes
considerable bandwidth when then try to scan our entire filesystems with SFS
across the internet)
Comment 2 Bill Nottingham 2003-02-19 13:52:14 EST
Done in 2.6-8.

Note You need to log in before you can comment on or make changes to this bug.