Bug 54868 - NFS sever file lock is broken in 2.4.9-6
NFS sever file lock is broken in 2.4.9-6
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 54891 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 01:46 EDT by hjl
Modified: 2014-01-21 17:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 04:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a testcase (1.30 KB, patch)
2001-10-22 01:46 EDT, hjl
no flags Details | Diff
The Connectathon Testsuite (83.50 KB, application/octet-stream)
2001-10-22 02:19 EDT, hjl
no flags Details
Client lockd kernel traceback (3.27 KB, text/plain)
2001-10-22 15:01 EDT, Bob Matthews
no flags Details
nlm_debug output of client lockd (606 bytes, text/plain)
2001-10-22 15:03 EDT, Bob Matthews
no flags Details
server lockd kernel traceback (1.24 KB, text/plain)
2001-10-22 15:04 EDT, Bob Matthews
no flags Details
server lockd nlm_debug output (256 bytes, text/plain)
2001-10-22 15:05 EDT, Bob Matthews
no flags Details
A patch (1.71 KB, patch)
2001-10-22 17:56 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2001-10-22 01:46:07 EDT
In a NFS mounted directory against the NFS
sever running kernel 2.4.9-6:

# gcc test.c
# a.out
Opening 'testlock' for writing.
Success!

Trying to get a read lock for 'testlock'


It fails to get a read lock from the NFS
server running 2.4.9-6.
Comment 1 hjl 2001-10-22 01:46:44 EDT
Created attachment 34561 [details]
a testcase
Comment 2 hjl 2001-10-22 01:50:01 EDT
Red Hat should run the Connectathon testsuite
before making any new kernels. I can provide
the patched source.
Comment 3 hjl 2001-10-22 02:18:05 EDT
It looks like both NFS server and client in
kernel 2.4.9-6 failed the Connectathon testsuite.
I am enclosing it here.
Comment 4 hjl 2001-10-22 02:19:26 EDT
Created attachment 34562 [details]
The Connectathon Testsuite
Comment 5 Gerald Teschl 2001-10-22 05:03:19 EDT
We have the same problem here on all our nfs servers. This brakes our
entire site;-(
Comment 6 Seth Vidal 2001-10-22 07:29:12 EDT
This will probably affect 7.2 as well - I think the kernels are relatively the same.

Comment 7 Bob Matthews 2001-10-22 14:58:36 EDT
I have been able to verify this with a client/server setup running 2.4.9-6smp on
two minimal 7.2 systems.

The client appears to be hanging in the first fcntl64 syscall generated by the
fcntl library call.  Strace shows that this syscall never returns.

Attached are relevant trace files including kernel tracebacks for lockd and the
test program on the client, nlm_debug output on the client, kernel traceback of
lockd on the server, and nlm_debug out on the server.
Comment 8 Bob Matthews 2001-10-22 15:01:40 EDT
Created attachment 34583 [details]
Client lockd kernel traceback
Comment 9 hjl 2001-10-22 15:02:44 EDT
NFS file locking is broken. I am working on it now.
It may take me a few days to fix it.
Comment 10 Bob Matthews 2001-10-22 15:03:09 EDT
Created attachment 34584 [details]
nlm_debug output of client lockd
Comment 11 Bob Matthews 2001-10-22 15:04:12 EDT
Created attachment 34585 [details]
server lockd kernel traceback
Comment 12 Bob Matthews 2001-10-22 15:05:31 EDT
Created attachment 34586 [details]
server lockd nlm_debug output
Comment 13 Bob Matthews 2001-10-22 15:23:27 EDT
*** Bug 54891 has been marked as a duplicate of this bug. ***
Comment 14 hjl 2001-10-22 17:56:07 EDT
Created attachment 34621 [details]
A patch
Comment 15 hjl 2001-10-22 17:57:04 EDT
I posted a patch which seems to work for me.
Comment 16 Leonard Evens 2001-10-23 23:25:12 EDT
We have applied the patch to make a custom kernel, and it appears to work
for us also.
Comment 17 Seth Vidal 2001-10-24 08:13:53 EDT
I built some new rpms of the 2.4.9-6 and 2.4.9-7(for 7.2) kernels that include
this patch.

I can put them some place public if its helpful to anyone
Comment 18 Arjan van de Ven 2001-10-24 08:16:15 EDT
I'll put up a kernel with the proposed patch up for testing soon; I'm just
trying to see if it's remotely seen (eg it boots etc)
Comment 19 Arjan van de Ven 2001-10-24 09:56:36 EDT
Please try the kernel at

http://people.redhat.com/arjanv/testkernels 

to see if it indeed works
Comment 20 Seth Vidal 2001-10-24 12:10:22 EDT
This will also need to be fixed on the alpha 2.4.9 kernel on 7.1

will the same patch work?
Comment 21 Anvil 2001-10-25 03:22:48 EDT
Hello gentlemen,
I got 2 little questions :
1/ Has enigma kernel the same problem ? If yes, will the 2.4.9-7.4 work on enigma ?
2/ May we have the kernel-header and kernel-source i386.rpm please ?
Comment 22 Gerald Teschl 2001-10-25 04:48:54 EDT
I had a look at the 7.2 kernel and found out that the svc code is correct,
however, the nfs patch from redhat undoes this. I removed the these lines
from the nfs patch and rebuild the rpms. The kernel now works fine under both
7.1 and 7.2.
Comment 23 Arjan van de Ven 2001-11-03 12:56:13 EST
This is fixed in yesterdays kernel erratum.
Thanks for reporting this!

Note You need to log in before you can comment on or make changes to this bug.