Bug 548760 - cannot connect to cdma network with sprint compass 597U using NetworkManager-0.7.997-2.git20091214.fc12.i686
cannot connect to cdma network with sprint compass 597U using NetworkManager...
Status: CLOSED DUPLICATE of bug 548520
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 09:30 EST by Jonathan Colon
Modified: 2010-01-04 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 18:03:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NetworkManager --no-daemon (2.46 KB, application/octet-stream)
2009-12-18 09:30 EST, Jonathan Colon
no flags Details
modem-manager --debug (1.80 KB, application/octet-stream)
2009-12-18 09:34 EST, Jonathan Colon
no flags Details
dmesg log (51.52 KB, application/octet-stream)
2009-12-18 09:38 EST, Jonathan Colon
no flags Details
lsusb log (447 bytes, application/octet-stream)
2009-12-18 09:39 EST, Jonathan Colon
no flags Details
Error Screenshot (50.28 KB, image/jpeg)
2009-12-18 11:14 EST, Jonathan Colon
no flags Details
Successful connection (4.67 KB, application/octet-stream)
2009-12-18 11:43 EST, Jonathan Colon
no flags Details
Successful connection (ModemManager Log) (8.38 KB, application/octet-stream)
2009-12-18 11:46 EST, Jonathan Colon
no flags Details

  None (edit)
Description Jonathan Colon 2009-12-18 09:30:48 EST
Created attachment 379218 [details]
NetworkManager --no-daemon

Description of problem:


Version-Release number of selected component (if applicable):

NetworkManager-0.7.997-2.git20091214.fc12.i686
ModemManager-0.2.997-2.git20091214.fc12.i686

How reproducible:


Steps to Reproduce:
1. install the update to NetworkManager (Update-testing repository)
2. try to connect to a cdma network
3. the icons activate but instantly deactivate the connection 
  
Actual results:

cannot connect to a cdma network using NetworkManager

Expected results:

successfully connect to a cdma using Networmanager

Additional info:

My ISP is sprint using Sierra wireless Compass 597U. Previously i can connect using NetworkManager.
Comment 1 Jonathan Colon 2009-12-18 09:34:49 EST
Created attachment 379220 [details]
modem-manager --debug

output of modem-manager --debug
Comment 2 Jonathan Colon 2009-12-18 09:38:02 EST
Created attachment 379224 [details]
dmesg log

output of dmesg
Comment 3 Jonathan Colon 2009-12-18 09:39:02 EST
Created attachment 379226 [details]
lsusb log
Comment 4 Valentin Cobelea 2009-12-18 09:48:53 EST
same 'bad' things for me.
Comment 5 Valentin Cobelea 2009-12-18 09:49:29 EST
I got a Huawei E220 3G modem on a Vodafone RO broadband 3G+ network.
Comment 6 Jonathan Colon 2009-12-18 09:53:44 EST
can you produce the same logs?

NetworkManager --no-daemon

modem-manager --debug

lsusb

dmesg
Comment 7 Valentin Cobelea 2009-12-18 10:03:21 EST
the logs are the same, except the dmesg which is showing me some output from my other stuff.
Comment 8 Valentin Cobelea 2009-12-18 10:03:46 EST
the differences are at the vendor / product.
Comment 9 Jonathan Colon 2009-12-18 11:13:16 EST
strange error adding a new cdma connection with NetworkManager:

Saving connection failed: (0) Can't write connection type 'cdma'

see nm-error.jpg attachment.
Comment 10 Jonathan Colon 2009-12-18 11:14:41 EST
Created attachment 379239 [details]
Error Screenshot

Error creating new CDMA connection with NM wizard...
Comment 11 Jonathan Colon 2009-12-18 11:28:20 EST
one open bug. for my problem? this error appear in my NM logs

NetworkManager pppd plugin does not work with latest pppd  
https://bugzilla.redhat.com/show_bug.cgi?id=548520
Comment 12 Jonathan Colon 2009-12-18 11:42:04 EST
yep back-porting to ppp-2.4.4-13.fc12 solve my connection problem and also solve the creating CDMA Connection wizard error see connection.log attachment.
Comment 13 Jonathan Colon 2009-12-18 11:43:57 EST
Created attachment 379244 [details]
Successful connection

Successful connection with NM and ppp version 2.4.4-13.fc12
Comment 14 Jonathan Colon 2009-12-18 11:46:29 EST
Created attachment 379248 [details]
Successful connection (ModemManager Log)

Successful connection output ModemManager Log
Comment 15 Dan Williams 2010-01-04 18:03:03 EST

*** This bug has been marked as a duplicate of bug 548520 ***

Note You need to log in before you can comment on or make changes to this bug.