Bug 54879 - rsync timesout during activ connection
Summary: rsync timesout during activ connection
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsync   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-22 15:21 UTC by Need Real Name
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-30 21:03:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-10-22 15:21:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.19 i686)

Description of problem:
My 2.4.6 has a feature (bug) that the
"--timeout=<seconds>" given on the client side breaks the
transfer after <seconds> - no matter how active the transfer is.

There was somekind of patch for this in the message archives
of the mailing list -
I have not tried to apply it.

Last time I read - the patch was not yet included in 2.4.7 pre.

Set timeout=0 (or no --timeout at all) - and give a try.

I do not know what the timeout means on the server side.

sh


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rsync --timeout=10 /tmp root@host:/tmp

	

Actual Results:  you get timeout while the connection is still verry
active(it is a know rsync bug)
check ther mailinglist archive

Expected Results:  it soulden't stop transverring

Additional info:

I think you get the picture:)
al though it is a low priority bug it would be nice to see a fix
package(sinds a fix is presend)

Comment 1 Bill Nottingham 2001-11-30 21:03:20 UTC
I can't reproduce this with 2.5.0 (it's available at
http://people.redhat.com/notting/rsync/, and will be in rawhide soon); does this
work for you?

Comment 2 Bill Nottingham 2002-11-25 21:55:40 UTC
closing, no response


Note You need to log in before you can comment on or make changes to this bug.