Bug 54881 - ReiserFS Issue with kernel 2.4.7-10
ReiserFS Issue with kernel 2.4.7-10
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 12:22 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 06:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-22 12:22:22 EDT
Description of Problem:
System crash while recovering journal of reiserfs. I realise that reiser is not your preferred journaling file system, but I had converted months ago and have been running 2.4.9 kernel on a reasonably standard 7.1 Redhat system.

While trying to upgrade (or install) Redhat 7.2, my system kept crashing. I tracked it down to one of my reiser partitions failing the journal recovery stage at startup. I ran debugreiserfs and it failed as well. Finally, I rebuilt the 2.4.7 kernel using the journal patch from the reiser home page. That fixed the problem, and then the standard 2.4.7 kernel that is in Redhat 7.2 worked OK.

Version-Release number of selected component (if applicable):
2,4,7

How Reproducible:
Easily, with the dump file of my disk partition that I created with debugreiserfs.

Steps to Reproduce:
1. Create 1 GB partition on a disk drive
2. Load the data I created using debugreiserfs
3. Execute reiserfsck on that partition.
4. Boom!

Actual Results:


Expected Results:


Additional Information:
Actually, the best thing to do is simply release a newer kernel version that you have verified contains the reiser patches. I am now running 2.4.12 at work, and it contains the journal patch.
Comment 1 Arjan van de Ven 2001-10-22 12:32:36 EDT
Actually we released a 2.4.9-ac10 based kernel today for other reasons; that
one should have the latest reiserfs patches just fine....

Note You need to log in before you can comment on or make changes to this bug.