Bug 548814 - Cannot access wifi (WPA-PSK) Access Point in booting
Cannot access wifi (WPA-PSK) Access Point in booting
Status: CLOSED DUPLICATE of bug 154348
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 12:56 EST by idak
Modified: 2014-03-16 23:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 13:07:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description idak 2009-12-18 12:56:23 EST
Description of problem:
Cannot access wifi (WPA-PSK) AP in booting

Version-Release number of selected component (if applicable):
initscripts-9.02-1.i686
wpa_supplicant-0.6.8-6.fc12.i686

Steps to Reproduce:
1. setup wpa_supplicant to use WPA-PSK
2. setup ifcfg-wlan0 with ONBOOT=yes

Actual results:
Cannot connect WPA-PSK Access Point

Expected results:
Should connect WPA-PSK Access Point

Additional info:
/etc/init.d/network depends on wpa_supplicant if ifcfg-wlan0 has ONBOOT=yes.
So network script needs to add "Required-Start" entry like the following
---
  #
  ### BEGIN INIT INFO
  # Provides: $network
+ # Required-Start: wpa_suplicant
  # Should-Start: iptables ip6tables
  # Short-Description: Bring up/down networking
  # Description: Bring up/down networking
---
Comment 1 Bill Nottingham 2009-12-18 13:07:44 EST
If you want to use WPA, use NetworkManager.

*** This bug has been marked as a duplicate of bug 154348 ***

Note You need to log in before you can comment on or make changes to this bug.