This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 548819 - gnome-screensaver cannot be reliably inhibited
gnome-screensaver cannot be reliably inhibited
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 13:03 EST by Kevin L. Mitchell
Modified: 2015-01-14 18:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 11:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin L. Mitchell 2009-12-18 13:03:41 EST
Description of problem:

Apparently, gnome-screensaver (gnome-screensaver-2.26.1-3.fc11.x86_64) cannot be inhibited reliably on Fedora 11.  I have noted two failure modes:

1) xdg-screensaver attempts to inhibit gnome-screensaver by executing gnome-screensaver-command -p in a loop, once every 59 seconds.  Apparently, gnome-screensaver now ignores -p unless it's actually active, meaning that the screensaver engages, then releases on the next execution of that command.  This is a change from gnome-screensaver on Fedora 10, where this worked just fine.

2) gnome-screensaver-command -i -n "<window name>" -r "<reason>" will successfully inhibit the screensaver from engaging.  Ever.  Apparently, the only way to uninhibit the screensaver at all is to kill it and restart it.  Additionally, gnome-screensaver-command --query in another window claims that the screensaver is not inhibited, even though it clearly never re-engages.

I believe I've also tried DBus methods on this system and found that, although I could get gnome-screensaver to inhibit and gnome-screensaver-command --query to report the inhibit status, I could not get it to uninhibit, even after gnome-screensaver-command --query reports an uninhibited status.  I also note that there are a number of DBus method changes between Fedora 10 and Fedora 11, indicating that something major has happened in gnome-screensaver.

Version-Release number of selected component (if applicable):

gnome-screensaver-2.26.1-3.fc11.x86_64

How reproducible:

Perfectly reproducible, so far as I can tell.

Steps to Reproduce:
1. Attempt to inhibit screensaver
2. Watch screensaver either engage, or watch screensaver never engage after uninhibiting the screensaver.
3.
  
Actual results:

Screensaver either does not inhibit or is inhibited forever; there appears to be no middle ground.

Expected results:

It should be possible to inhibit the screensaver, perform whatever task required the inhibiting, then reliably uninhibit the screensaver.  If gnome-screensaver simply reset its idle time when gnome-screensaver-command -p was executed, that would be sufficient.  If uninhibiting actually worked, that would also be nice.  Ideally, *both* of these methods should result in reliable inhibiting/uninhibiting behavior.

Additional info:
Comment 1 Carl-Johan Kjellander 2010-01-04 16:23:30 EST
I'm seeing this on F12 as well.

gnome-screensaver-2.28.0-8.fc12.x86_64

I play my movies like this and it worked in F10, but not 
after an upgrade:

 mplayer -fs -softvol -softvol-max 1000 -heartbeat-cmd 'gnome-screensaver-command -p' -framedrop *.mkv *.avi

The screensaver still comes on. I tried this as well
before playing the movie:

 while true ; do sleep 10 ; gnome-screensaver-command -p ; done

Then after 10 minutes it still started fading out the screen, but
it actually didn't start the screensaver, GLMatrix which is my default,
but it super quickly faded back up and I could continue watching.
Comment 2 Alexey Kuznetsov 2010-03-06 02:41:36 EST
gnome-screensaver-2.28.3-1.fc12.x86_64 same problem.
Comment 3 Bug Zapper 2010-04-28 07:36:19 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-06-28 11:34:44 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.