Bug 548827 - yumex core dump after gtk2 is updated
yumex core dump after gtk2 is updated
Status: CLOSED DUPLICATE of bug 548849
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
12
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 13:16 EST by Phillip Lynn
Modified: 2009-12-21 19:08 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-21 19:08:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Without "GDK_NATIVE_WINDOWS=1"; All F12 Updates (9.54 KB, text/plain)
2009-12-21 07:11 EST, Dirk Schlüter
no flags Details
With "GDK_NATIVE_WINDOWS=1"; All F12 Updates (6.92 KB, text/plain)
2009-12-21 07:11 EST, Dirk Schlüter
no flags Details

  None (edit)
Description Phillip Lynn 2009-12-18 13:16:16 EST
Description of problem:
When attempting to run yumex system starts to run but then exits with a 
Segmentation fault      (core dumped).



Version-Release number of selected component (if applicable):
yumex-2.9.4-1.fc12.noarch

How reproducible:


Steps to Reproduce:
1.did yum update this morning 12/18/09. afternoon ran yumex
2.
3.
  
Actual results:


Expected results:


Additional info:

Linux plynn55 2.6.31.6-166.fc12.x86_64 #1 SMP Wed Dec 9 10:46:22 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

[plynn55@plynn55 asus_laptop]$ cat infos
Asus Laptop Support 0.42
Model reference    : N71Vn
SFUN value         : 0x1a18f7
DSDT length        : 49602
DSDT checksum      : 38
DSDT revision      : 1
OEM id             : N71Vx
OEM table id       : N71Vx202
OEM revision       : 0x202
ASL comp vendor id : INTL
ASL comp revision  : 0x20051117



[plynn55@plynn55 ~]$  yumex
running
Current Settings
    autorefresh: True
    branding_title: 'Yum Extender NextGen'
    color_install: 'darkgreen'
    color_normal: 'black'
    color_obsolete: 'blue'
    color_update: 'red'
    debug: False
    disable_repo_page: False
    plugins: True
    proxy: ''
    recentdays: 14
    repo_exclude: ['debug', 'source']
    win_height: 846
    win_sep: 300
    win_width: 1600
    yumdebuglevel: 2
/usr/lib/python2.6/site-packages/guihelpers/__init__.py:199: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
/usr/lib/python2.6/site-packages/yumexgui/gui.py:179: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltip = gtk.Tooltips()
/usr/lib/python2.6/site-packages/yumexgui/gui.py:206: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltip.set_tip(button, tooltip)
Can't detect the network connection state
Starting yum child process
Downloaded : fedora/group_gz ( 390 k )
Downloaded : updates/group_gz ( 388 k )
History Enabled
/usr/bin/yumex: line 5:  2834 Segmentation fault      (core dumped) /usr/bin/python /usr/share/yumex/yumex.pyc $*
Comment 1 Phillip Lynn 2009-12-18 13:56:59 EST
I forgot to set the Priority to High or Urgent.
Comment 2 David Batson 2009-12-19 08:19:28 EST
The update of gtk2* causes this.  Reverting back to the previous version allows yumex to run normally.
Comment 3 Tim Lauridsen 2009-12-19 09:41:25 EST
Phillip, could you check if you havde update gtk2 recently and i downgrade gtk2 solves the issue.
Comment 4 Tim Lauridsen 2009-12-19 09:42:38 EST
David, could you report the gtk2 release causing the error.
Comment 5 David Batson 2009-12-19 10:50:37 EST
One of the following two files.
gtk2-2.18.5-3.fc12
gtk2-immodule-xim-2.18.5-3.fc12

As reported in the following thread.
http://forums.fedoraforum.org/showthread.php?t=236523
Comment 6 David Batson 2009-12-19 11:29:55 EST
chepioq reports in the thread above that gtk2-immodule-xim is the problem rpm.
Comment 7 Eric Tanguy 2009-12-19 11:43:42 EST
I confirm that remove gtk2-immodule-xim solve the problem. 
$ repoquery --whatrequires --alldeps gtk2-immodule-xim returns nothing
Comment 8 dominique 2009-12-19 11:58:57 EST
What is the utility of gtk2-immodule-xim ?
Comment 9 Tim Lauridsen 2009-12-20 09:42:17 EST
yumex have no speciel need for gtk2-immodule-xim, I don't know what is does.

yumex uses pygtk (part of gtk) for the user interface and gtk2-immodule-xim must somehow blowup some of the pygtk parts used by yumex.
Comment 10 Tim Lauridsen 2009-12-20 09:48:34 EST
Matthias:

Do you have any idea why the latest gtk2-immodule-xim makes yumex segfault ?
Comment 11 jim tate 2009-12-20 14:17:21 EST
Removing gtk2-immodule-xim also help me get rid of Yumex crashing.

But now I have another problem When I get into Yumex The Updates-testing is always enabled and I have to do a uncheck on updates-testing and refresh to get correct updates.
Comment 12 Matthias Clasen 2009-12-20 20:57:22 EST
gtk2-immodule-xim is an input method module that gets loaded by GTK+ if your system is configured to use xim as input method framework. 

Have we established that gtk2-immodule-xim-2.18.4 does not cause this problem, but 2.18.5 does ?

Does setting GDK_NATIVE_WINDOWS=1 make the issue go away ?

Can we get a stacktrace ?
Comment 13 David Batson 2009-12-20 23:10:08 EST
I checked my yum log and gtk2-immodule-xim was updated to gtk2-immodule-xim-2.18.4-3.fc12.i686 on my system Dec. 13th.  On Dec. 14th I ran Yumex without issue and installed some fonts.  On Dec. 18th, gtk2-immodule-xim was updated to gtk2-immodule-xim-2.18.5-3.fc12.i686.  After that, Yumex would crash.  I uninstalled gtk2-immodule-xim-2.18.4-3.fc12.i686 and now Yumex runs fine.

Don't know about "GDK_NATIVE_WINDOWS=1" as I don't know where enter it.  Don't know how to get stacktrace either.
Comment 14 Eric Tanguy 2009-12-21 01:24:59 EST
(In reply to comment #12)
> gtk2-immodule-xim is an input method module that gets loaded by GTK+ if your
> system is configured to use xim as input method framework. 
> 
> Have we established that gtk2-immodule-xim-2.18.4 does not cause this problem,
> but 2.18.5 does ?

> 
> Does setting GDK_NATIVE_WINDOWS=1 make the issue go away ?
> 
> Can we get a stacktrace ?  

I reinstalled 2.18.3 then 2.18.4 (from updates-testing) and then 2.18.5 and now yumex run fine with gtk2-immodule-xim-2.18.5 

Can't understand ....
Comment 15 Eric Tanguy 2009-12-21 01:34:21 EST
(In reply to comment #14)
> (In reply to comment #12)
> > gtk2-immodule-xim is an input method module that gets loaded by GTK+ if your
> > system is configured to use xim as input method framework. 
> > 
> > Have we established that gtk2-immodule-xim-2.18.4 does not cause this problem,
> > but 2.18.5 does ?
> 
> > 
> > Does setting GDK_NATIVE_WINDOWS=1 make the issue go away ?
> > 
> > Can we get a stacktrace ?  
> 
> I reinstalled 2.18.3 then 2.18.4 (from updates-testing) and then 2.18.5 and now
> yumex run fine with gtk2-immodule-xim-2.18.5 
> 
> Can't understand ....  

But after a reboot the problem go back.
with GDK_NATIVE_WINDOWS=1 yumex run fine

Can't know how to get a stacktrace
Comment 16 Dirk Schlüter 2009-12-21 07:10:43 EST
(In reply to comment #12)
> Does setting GDK_NATIVE_WINDOWS=1 make the issue go away ?
> 
> Can we get a stacktrace ?  

Yes. With "GDK_NATIVE_WINDOWS=1" yumex works as expected. 

As attachment, to strace files. 

1.) Without "GDK_NATIVE_WINDOWS=1"

$ strace -o yumex_strace.txt yumex
running
Current Settings
    autorefresh: True
    branding_title: 'Yum Extender NextGen'
    color_install: 'darkgreen'
    color_normal: 'black'
    color_obsolete: 'blue'
    color_update: 'red'
    debug: False
    disable_repo_page: False
    plugins: True
    proxy: ''
    recentdays: 14
    repo_exclude: ['debug', 'source']
    win_height: 950
    win_sep: 300
    win_width: 1325
    yumdebuglevel: 2
/usr/lib/python2.6/site-packages/guihelpers/__init__.py:199: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
wlan0 (iwlagn) is connected
eth0 (r8169) is connected
/usr/lib/python2.6/site-packages/yumexgui/gui.py:179: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltip = gtk.Tooltips()
/usr/lib/python2.6/site-packages/yumexgui/gui.py:206: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltip.set_tip(button, tooltip)
wlan0 (iwlagn) is connected
eth0 (r8169) is connected
Connected to an network
wlan0 (iwlagn) is connected
eth0 (r8169) is connected
Starting yum child process
YUM: Geladene Plugins: presto
History Enabled
/usr/bin/yumex: Zeile 5:  6620 Speicherzugriffsfehler  (Speicherabzug geschrieben) /usr/bin/python /usr/share/yumex/yumex.pyc $*

2.) With "GDK_NATIVE_WINDOWS=1":

$ export GDK_NATIVE_WINDOWS=1; strace -o yumex_strace_2.txt yumex
running
Current Settings
    autorefresh: True
    branding_title: 'Yum Extender NextGen'
    color_install: 'darkgreen'
    color_normal: 'black'
    color_obsolete: 'blue'
    color_update: 'red'
    debug: False
    disable_repo_page: False
    plugins: True
    proxy: ''
    recentdays: 14
    repo_exclude: ['debug', 'source']
    win_height: 950
    win_sep: 300
    win_width: 1325
    yumdebuglevel: 2
/usr/lib/python2.6/site-packages/guihelpers/__init__.py:199: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
wlan0 (iwlagn) is connected
eth0 (r8169) is connected
/usr/lib/python2.6/site-packages/yumexgui/gui.py:179: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltip = gtk.Tooltips()
/usr/lib/python2.6/site-packages/yumexgui/gui.py:206: DeprecationWarning: Use the new widget gtk.Tooltip
  self.tooltip.set_tip(button, tooltip)
wlan0 (iwlagn) is connected
eth0 (r8169) is connected
Connected to an network
wlan0 (iwlagn) is connected
eth0 (r8169) is connected
Starting yum child process
YUM: Geladene Plugins: presto
History Enabled
Stopping yum child process
ERROR: Yum backend did not close nicely in time
Comment 17 Dirk Schlüter 2009-12-21 07:11:24 EST
Created attachment 379604 [details]
Without "GDK_NATIVE_WINDOWS=1"; All F12 Updates
Comment 18 Dirk Schlüter 2009-12-21 07:11:47 EST
Created attachment 379605 [details]
With "GDK_NATIVE_WINDOWS=1"; All F12 Updates
Comment 19 Matthias Clasen 2009-12-21 10:28:31 EST
strace is not what I was interested in, actually. I need a stacktrace from when it crashes, preferably while running with --sync. My attempts at getting a stacktrace ended in gdb eating all my memory and bringing my system to a grinding halt...
Comment 20 Phillip Lynn 2009-12-21 10:34:18 EST
Ok,  I removed gtk2-imimodule-xim-2.18.5-3.fc12.x86_64 and I was able to run yumex and add a package with no issues.  I checked my repositories and updates-testing was not selected.  Will be doing further testing.
Comment 21 David Batson 2009-12-21 13:02:34 EST
When I tried to send in the abrt report on this issue, I experienced the same gobbling up of resources.  I ran top and found that Python was using ~93% of my CPU and ~74% of my memory (I have 1GB RAM and 2GB Swap).  The abrt said something about Python being the problem.  Perhaps if some successful abrt reports were sent, they would be about Python.
Comment 22 Matthias Clasen 2009-12-21 13:07:43 EST
well, yumex is a python app...
Comment 23 Matthias Clasen 2009-12-21 13:21:44 EST
filed an abrt bug here: https://bugzilla.redhat.com/show_bug.cgi?id=549452
Comment 24 Dave Malcolm 2009-12-21 18:38:50 EST
I've been tracking this as bug 548849 ("SIGSEGV in yumex due to infinite recursion in "temporary_disable_extension_events" in gdk_window_ensure_native called by /usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so").

There are various good backtraces in the various dupes of that bug:
  - attachment 379287 [details] to bug 548849 shows the overall structure (albeit with almost 200000 frames!) but doesn't identify the infinitely-recursing function
  - attachment 379350 [details] to bug 548927 and attachment 379727 [details] to bug 549548 identify the infinite recursion as being in "temporary_disable_extension_events"

Probably should close one of this bug and bug 548849 as a dup of the other.
Comment 25 Dave Malcolm 2009-12-21 19:08:25 EST
Marking this one as a dup of 548849 (as this was the id that mclasen used in this commit: 
http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-18&id=9ac1b6830c3b9820f50b61395662771a5cc22383
)

*** This bug has been marked as a duplicate of bug 548849 ***

Note You need to log in before you can comment on or make changes to this bug.