Bug 548833 - Easytag does't write Xiph-tags correctly. [NEEDINFO]
Summary: Easytag does't write Xiph-tags correctly.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: easytag
Version: 20
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 818468 (view as bug list)
Depends On: 951265
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-18 18:38 UTC by Steve
Modified: 2014-01-18 04:24 UTC (History)
4 users (show)

Fixed In Version: easytag-2.1.8-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-12 05:02:45 UTC
Type: ---
bugzilla: needinfo? (extras-qa)


Attachments (Terms of Use)
First one (100.35 KB, image/png)
2009-12-18 18:39 UTC, Steve
no flags Details
Second one (31.26 KB, image/png)
2009-12-18 18:40 UTC, Steve
no flags Details
Flac file (3.01 MB, application/octet-stream)
2009-12-18 18:41 UTC, Steve
no flags Details

Description Steve 2009-12-18 18:38:55 UTC
Description of problem:
See the two pictures (Screenshot-EasyTAG 2.1.6.png & Screenshot-11 -Properties.png). The firt one is what easytag writes. The second one is how other systems (testet on linux & mac) read the tag.

Version-Release number of selected component (if applicable):
easytag-2.1.6-2.fc12.i686
flac-1.2.1-6.fc12.i686
taglib-1.6.1-2.fc12.i686
libid3tag-0.15.1b-9.fc12.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Steve 2009-12-18 18:39:35 UTC
Created attachment 379266 [details]
First one

Comment 2 Steve 2009-12-18 18:40:04 UTC
Created attachment 379267 [details]
Second one

Comment 3 Steve 2009-12-18 18:41:10 UTC
Created attachment 379268 [details]
Flac file

Comment 4 Matthias Saou 2009-12-19 17:48:18 UTC
Could this have something to do with the "Write ID3 tags in FLAC files (in addition to FLAC tag" setting from easytag? Does changing it produce the same result?

The next question would be : Have you managed to get the wanted tag written to then read from those FLAC files using the same programs to read but a different program to write?

Because the problem could be just about anything and needs to be nailed down :
 * Easytag truncating the fields when it finds a dash (you could try long fields without dashes too)
 * The FLAC tags not supporting dashes inside the fields (I don't know enough)
 * Multiple tags being written, and one with limitations being read first
etc.

Comment 5 Steve 2009-12-19 19:18:10 UTC
(In reply to comment #4)
> Could this have something to do with the "Write ID3 tags in FLAC files (in
> addition to FLAC tag" setting from easytag? Does changing it produce the same
> result?

Yes, the same result.

> 
> The next question would be : Have you managed to get the wanted tag written to
> then read from those FLAC files using the same programs to read but a different
> program to write?

Yes, when i write the tag with rhythmbox it works.

Comment 6 Steve 2009-12-23 09:40:01 UTC
No fixes until yet?

Comment 7 Steve 2010-01-09 14:30:12 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Could this have something to do with the "Write ID3 tags in FLAC files (in
> > addition to FLAC tag" setting from easytag? Does changing it produce the same
> > result?
> 
> Yes, the same result.
> 
> > 
> > The next question would be : Have you managed to get the wanted tag written to
> > then read from those FLAC files using the same programs to read but a different
> > program to write?
> 
> Yes, when i write the tag with rhythmbox it works.    

No, rhythmbox is the only player who can read the tag.

Comment 8 Steve 2010-01-24 10:51:20 UTC
Ok. This is definitively a problem of easytag. If i write the tag with rhythmbox or another "tagger", then all other players can red the tag. If there is a " - " in the tag, then easytag does not write the tag correctly. And this happens only with the FLAC-tag, there is no problem with MP3 or similar.

Comment 9 Steve 2010-01-24 10:51:21 UTC
Ok. This is definitively a problem of easytag. If i write the tag with rhythmbox or another "tagger", then all other players can red the tag. If there is a " - " in the tag, then easytag does not write the tag correctly. And this happens only with the FLAC-tag, there is no problem with MP3 or similar.

Comment 10 Steve 2010-01-26 13:41:25 UTC
Easytag writes a "\\" instead of a " - ". And most players (or all?) can't read the tag after the "\\". I saw this by opening the FLAC-files with Mp3tag (Windows program) with Wine.

Please fix this!

Comment 11 Matthias Saou 2010-04-08 09:59:32 UTC
A tested patch for this would be more than welcome. I've just searched the easytag mailing-list, but didn't find anyone reporting this with a possible fix.

Comment 12 Matthias Saou 2010-04-30 15:11:42 UTC
I was looking some more into this, and just found the upstream report, which points back to here. No replies yet, though.
http://sourceforge.net/tracker/index.php?func=detail&aid=2949587&group_id=5216&atid=105216

Comment 13 Steve 2010-04-30 15:14:57 UTC
Yes this upstream report if from me ;o|

Comment 14 Steve 2010-05-27 15:55:40 UTC
Still not fixed...

easytag-2.1.6-5.fc13.i686

Comment 15 Matthias Saou 2010-05-28 15:07:04 UTC
Yeah, I've included only fixes for which tested patches were already available. If you ever have someone provide a patch to fix the issue, I'll be more than glad to include it.

Comment 16 Steve 2010-05-28 15:29:34 UTC
I know that. Just went change version to 13..

Comment 17 Steve 2010-07-04 12:42:15 UTC
Ogg is also affected.

Comment 18 Steve 2011-07-11 07:17:36 UTC
Something is going on.. ;O)

http://sourceforge.net/tracker/?func=detail&atid=105216&aid=2949587&group_id=5216

Comment 19 Steve 2012-06-06 19:05:36 UTC
This bug is not fixed in easytag-2.1.7-1.fc17.

Comment 20 Steve 2013-01-20 09:59:48 UTC
This bug is not fixed in easytag-2.1.7-2.fc18. Changing version to 18.

Comment 21 Steve 2013-07-03 14:37:08 UTC
This bug is not fixed in easytag-2.1.7-3.fc19.

Comment 22 David King 2013-07-03 22:06:37 UTC
EasyTAG 2.1.8 has settings to disable the tag splitting "feature", where any tag which has a " - " is split into multiple tags, so updating the package to 2.1.8 or above would fix this bug.

Comment 23 Steve 2013-07-18 14:53:49 UTC
easytag-2.1.8-1.3.x86_64.rpm for openSUSE Factory is working very well with this feature on F19.

http://pkgs.org/opensuse-factory/opensuse-oss-x86_64/easytag-2.1.8-1.3.x86_64.rpm.html

Comment 24 Steve 2013-08-02 07:03:38 UTC
Can someone please update this package to the recent version?

Comment 25 Steve 2013-11-20 07:02:06 UTC
Why it takes so long to update this package?

Comment 26 Steve 2013-12-18 07:08:13 UTC
Bug seems not to be fixed in F20. Changing version to 20. Please update Easytag to version 2.1.8.

Comment 27 David King 2014-01-09 12:03:25 UTC
*** Bug 818468 has been marked as a duplicate of this bug. ***

Comment 28 Fedora Update System 2014-01-09 12:38:39 UTC
easytag-2.1.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/easytag-2.1.8-1.fc19

Comment 29 Fedora Update System 2014-01-09 12:49:11 UTC
easytag-2.1.8-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/easytag-2.1.8-1.fc20

Comment 30 Steve 2014-01-09 15:46:10 UTC
Finally, after four Years......... Thanks!

Comment 31 Fedora Update System 2014-01-10 07:43:09 UTC
Package easytag-2.1.8-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing easytag-2.1.8-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0507/easytag-2.1.8-1.fc20
then log in and leave karma (feedback).

Comment 32 Fedora Update System 2014-01-12 05:02:45 UTC
easytag-2.1.8-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2014-01-18 04:24:08 UTC
easytag-2.1.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.