Bug 548834 - uname -i started returning unknown
uname -i started returning unknown
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 13:47 EST by Bruno Wolff III
Modified: 2009-12-19 11:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-19 04:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-12-18 13:47:13 EST
Description of problem:
I am running rawhide with f12 kernels (due to f13 kernels not booting) and recently uname -i started returning unknown instead of i386 which broke some scripts I was using.

Version-Release number of selected component (if applicable):
coreutils-8.2-3.fc13.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2009-12-19 02:48:53 EST
Thanks for report, this was caused by my drop of one hacky patch for uname which never got upstream. It seems that I have to put at least parts of that patch back - but I'll check if there is some other way... sorry for troubles...
Comment 2 Ondrej Vasik 2009-12-19 03:03:29 EST
Looking into http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=193170 it seems there is no easy way to get the correct results other way - no <sys/systeminfo.h> header... I'll put the sysinfo patch back - except the part for athlon, which is really hacky and unreliable.
Comment 3 Ondrej Vasik 2009-12-19 04:06:32 EST
Fixed in coreutils-8.2-4.fc13. Closing RAWHIDE.
Comment 4 Bruno Wolff III 2009-12-19 11:37:45 EST
I am confirming that it is working again for me.
Thanks for fixing this quickly!

Note You need to log in before you can comment on or make changes to this bug.