Bug 548873 - user not prompted for username and password when printing to authenticated IPP queue
Summary: user not prompted for username and password when printing to authenticated IP...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 549785
TreeView+ depends on / blocked
 
Reported: 2009-12-18 22:21 UTC by Aram Agajanian
Modified: 2010-01-04 21:18 UTC (History)
2 users (show)

Fixed In Version: 1.4.2-20.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 549785 (view as bug list)
Environment:
Last Closed: 2009-12-27 20:33:01 UTC


Attachments (Terms of Use)
error_log where root submits a job on the command line (22.23 KB, text/plain)
2009-12-23 15:40 UTC, Aram Agajanian
no flags Details


Links
System ID Priority Status Summary Last Updated
CUPS Bugs and Features 3458 None None None Never

Description Aram Agajanian 2009-12-18 22:21:11 UTC
Description of problem:
When sending a job to an authenticated IPP queue, I expect to be prompted for a username and password.  This doesn't happen and the job gets stuck.

Version-Release number of selected component (if applicable):
cups-1.4.2-7.fc12.x86_64

How reproducible:
Happens every time.

Steps to Reproduce:
1.  Add a new printer that prints to an authenticated IPP queue.
2.  Send a print job to that printer.
3.
  
Actual results:
The print job doesn't get printed.  The command "lpstat -t", produces output like:

[agajania@comp1 ~]$ lpstat -t
scheduler is running
device for csoffice: ipp://hopper.cs.newpaltz.edu:7631/printers/csoffice?encryption=always
csoffice accepting requests since Fri 18 Dec 2009 05:09:00 PM EST
printer csoffice now printing csoffice-0.  enabled since Fri 18 Dec 2009 05:09:00 PM EST
	Unable to get printer status (Unauthorized)!
csoffice-31             root              1024   Fri 18 Dec 2009 05:09:00 PM EST


Expected results:
The user should be asked for a username and password.

Additional info:

The prompting for a username and password was the default behavior in Fedora 11.

Comment 1 Tim Waugh 2009-12-22 13:20:14 UTC
Reported upstream with patch.

Comment 2 Tim Waugh 2009-12-22 13:20:31 UTC
Also affects Fedora 11 so changing version.

Comment 3 Aram Agajanian 2009-12-22 20:34:08 UTC
I have installed release 1.4.2-19.fc12 of cups and cups-libs.

Regarding printing from GNOME apps:

While still using release 1.4.2-7.fc12 earlier today, I noticed that the username and password pop-up was coming up.  I'm not sure when that started working, but it is the first time that I can remember seeing it in F12.

Regarding printing from the command line:

This works in 1.4.2-19.fc12 but was not working in 1.4.2-7.fc12.  Now, when I print from the command line, the username and password pop-up appears and the document seems to print properly.

Regarding printing from the command line as root:

This doesn't work.  When I try this, the status in lpstat -t becomes 
"/usr/lib/cups/backend/ipp failed".  The job doesn't block the queue, though.  Subsequent user jobs get printed out.  If I try to cancel the job, however, cups seems to become unusable.  (Restarting cups restored service.)  I have been able to remove the job by deleting files from /var/spool/cups.

Comment 4 Tim Waugh 2009-12-23 11:22:44 UTC
Please run 'service cups restartlog' as root, submit a job from the command line as root, then when it fails attach /var/log/cups/error_log to this bug report using the "Add an attachment" link above.  Thanks.

Comment 5 Aram Agajanian 2009-12-23 15:40:11 UTC
Created attachment 380044 [details]
error_log where root submits a job on the command line

Comment 6 Tim Waugh 2009-12-23 16:48:05 UTC
The job stops normally due to lack of authentication.

Just authenticate the job by right-clicking on the printer in system-config-printer, selecting 'View Print Queue, right-clicking on the held job, and selecting 'Authenticate'.

Comment 7 Fedora Update System 2009-12-27 20:32:10 UTC
cups-1.4.2-20.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-01-04 21:18:10 UTC
cups-1.4.2-20.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.