Bug 5489 - ftp install fails: no route to host, other weirdness
Summary: ftp install fails: no route to host, other weirdness
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-04 16:02 UTC by Pekka Savola
Modified: 2015-01-07 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-20 15:32:06 UTC


Attachments (Terms of Use)

Description Pekka Savola 1999-10-04 16:02:44 UTC
I boot RH6.1 using bootnet.img.  There doesn't seem to be an
X installer for bootnet; well, I like the menu system better
anyway.

However, ftp install from our local ftp server fails
miserably.  The installer loads stage2.img and hdlist just
fine (as I can see from ftpd logs), but when it should begin
transferring the actual files, I get some nasty errors.

If I use use FQDN of the ftp site (ourftp.xxx.fi):
[irrelevant info cut off]
ftplib.py line 117 in connect
IOError: [Errno ftp error]
(113, 'No route to host')

And if I use the IP number of the site:
[some stuff cut off]
todo.py line 1442
db=rpm.opendb(1,self.instPath)
rpm.error=Cannot open

I have tried custom and pre-packaged installations.  The
computer has SMC Etherpower II and 3Com 905b NIC's, neither
work.  Removing the other physically did no good.

After trying to install RH6.1 like 5-6 times, I used RH60's
bootnet.img to install that from the same ftp server.  It
worked like a charm.

The installer worked fine (although pretty slowly,
considering it's a 100BaseTx network) on a similar box
with Tulip and Intel EtherExpress Pro 100 NIC's.

Comment 1 Jay Turner 1999-10-20 15:32:59 UTC
The GUI installer is only available for NFS and CDROM installations,
so that answers that question.  As for the FTP problems which you are
seeing, are you giving a trailing space on the path to the source
files (i.e.  "/mnt/test/cartman/i386/" instead of
"/mnt/test/cartman/i386")  We have reports that giving the trailing
space can cause serious problems.  Reopen this bug if you are still
having problems.

Comment 2 schwim 1999-12-24 18:57:59 UTC
I too have had this problem.  Plus, once I finally did get the net install to
complete "successfully" I was left with a system that would not boot
completely.  In one case, I did get it to boot, but there were all sorts of
kernel version errors, and missing modules, etc.


Note You need to log in before you can comment on or make changes to this bug.