Bug 54894 - Location of jed.rc is wrong in man page
Summary: Location of jed.rc is wrong in man page
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: jed   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-22 19:45 UTC by Michael Schwendt
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-01 10:04:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2001-10-22 19:45:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
"man jed" says:

    /etc/jed.rc
           The system wide configuration file.

But the location is: /usr/share/jed/lib/jed.rc


Version-Release number of selected component (if applicable):
0.99.12-1

How reproducible:
Always


Additional info:
Roswell has introduced /etc/jed.conf, but /usr/share/jed/lib/jed.rc is
still loaded.

Comment 1 Michael Schwendt 2001-11-10 01:34:52 UTC
Loading of /usr/share/jed/lib/jed.rc from /usr/share/jed/lib/site.sl is broken.

/usr/share/jed/lib/jed.rc is not loaded at all (but would be easy to fix).

When  /usr/share/jed/lib/defaults.sl  is present, /etc/jed.conf is not loaded at
all.

Comment 2 Michael Schwendt 2001-11-10 02:10:36 UTC
And if that sounded confusing, here's the short version:

/etc/jed.conf  ought to be documented in "man jed" because the old mechanism for
loading system wide defaults works no longer. /usr/share/jed/lib/jed.rc is
effectively disabled due to IMHO questionable code in site.sl.

Comment 3 Karsten Hopp 2004-04-01 10:04:53 UTC
fixed in current releases

Comment 4 Michael Schwendt 2004-04-01 10:19:12 UTC
Not true for jed-0.99.16-3, but I've switched to Emacs again long ago.


Note You need to log in before you can comment on or make changes to this bug.